summaryrefslogtreecommitdiff
path: root/distro/packages/patches/tar-gets-undeclared.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-10-27 15:30:08 +0200
committerLudovic Courtès <ludo@gnu.org>2012-10-27 15:32:40 +0200
commitbfb3c3d03a168002d77631a653457556a96d9bdd (patch)
tree472c34a4351fd2d54bdea590c50b6b7d5b567f02 /distro/packages/patches/tar-gets-undeclared.patch
parentfc2f38023bf95604b2eac73bee336b4c3909b480 (diff)
downloadguix-patches-bfb3c3d03a168002d77631a653457556a96d9bdd.tar
guix-patches-bfb3c3d03a168002d77631a653457556a96d9bdd.tar.gz
build: Move `distro/patches' to `distro/packages/patches'.
* distro/patches: Move directory to... * distro/packages/patches: ... here. * Makefile.am (dist_patch_DATA): Adjust accordingly. * pre-inst-env.in (DISTRO_PATCH_DIRECTORY): Likewise.
Diffstat (limited to 'distro/packages/patches/tar-gets-undeclared.patch')
-rw-r--r--distro/packages/patches/tar-gets-undeclared.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/distro/packages/patches/tar-gets-undeclared.patch b/distro/packages/patches/tar-gets-undeclared.patch
new file mode 100644
index 0000000000..301a09dde1
--- /dev/null
+++ b/distro/packages/patches/tar-gets-undeclared.patch
@@ -0,0 +1,26 @@
+This patch is needed to allow builds with newer versions of
+the GNU libc (2.16+).
+
+This is a backport of this patch:
+
+commit 66712c23388e93e5c518ebc8515140fa0c807348
+Author: Eric Blake <eblake@redhat.com>
+Date: Thu Mar 29 13:30:41 2012 -0600
+
+ stdio: don't assume gets any more
+
+--- tar-1.26/gnu/stdio.in.h 2012-07-02 14:28:45.000000000 +0200
++++ tar-1.26/gnu/stdio.in.h 2012-07-02 14:28:50.000000000 +0200
+@@ -160,12 +160,6 @@ _GL_WARN_ON_USE (fflush, "fflush is not
+ "use gnulib module fflush for portable POSIX compliance");
+ #endif
+
+-/* It is very rare that the developer ever has full control of stdin,
+- so any use of gets warrants an unconditional warning. Assume it is
+- always declared, since it is required by C89. */
+-#undef gets
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+-
+ #if @GNULIB_FOPEN@
+ # if @REPLACE_FOPEN@
+ # if !(defined __cplusplus && defined GNULIB_NAMESPACE)