summaryrefslogtreecommitdiff
path: root/distro/packages/patches/m4-readlink-EINVAL.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-10-27 15:30:08 +0200
committerLudovic Courtès <ludo@gnu.org>2012-10-27 15:32:40 +0200
commitbfb3c3d03a168002d77631a653457556a96d9bdd (patch)
tree472c34a4351fd2d54bdea590c50b6b7d5b567f02 /distro/packages/patches/m4-readlink-EINVAL.patch
parentfc2f38023bf95604b2eac73bee336b4c3909b480 (diff)
downloadguix-patches-bfb3c3d03a168002d77631a653457556a96d9bdd.tar
guix-patches-bfb3c3d03a168002d77631a653457556a96d9bdd.tar.gz
build: Move `distro/patches' to `distro/packages/patches'.
* distro/patches: Move directory to... * distro/packages/patches: ... here. * Makefile.am (dist_patch_DATA): Adjust accordingly. * pre-inst-env.in (DISTRO_PATCH_DIRECTORY): Likewise.
Diffstat (limited to 'distro/packages/patches/m4-readlink-EINVAL.patch')
-rw-r--r--distro/packages/patches/m4-readlink-EINVAL.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/distro/packages/patches/m4-readlink-EINVAL.patch b/distro/packages/patches/m4-readlink-EINVAL.patch
new file mode 100644
index 0000000000..dd371584a7
--- /dev/null
+++ b/distro/packages/patches/m4-readlink-EINVAL.patch
@@ -0,0 +1,18 @@
+Newer Linux kernels would return EINVAL instead of ENOENT.
+The patch below, taken from Gnulib, allows the test to pass when
+these Linux versions are in use:
+https://lists.gnu.org/archive/html/bug-gnulib/2011-03/msg00308.html .
+
+diff --git a/tests/test-readlink.h b/tests/test-readlink.h
+index 08d5662..7247fc4 100644
+--- a/tests/test-readlink.h
++++ b/tests/test-readlink.h
+@@ -38,7 +38,7 @@ test_readlink (ssize_t (*func) (char const *, char *, size_t), bool print)
+ ASSERT (errno == ENOENT);
+ errno = 0;
+ ASSERT (func ("", buf, sizeof buf) == -1);
+- ASSERT (errno == ENOENT);
++ ASSERT (errno == ENOENT || errno == EINVAL);
+ errno = 0;
+ ASSERT (func (".", buf, sizeof buf) == -1);
+ ASSERT (errno == EINVAL);