summaryrefslogtreecommitdiff
path: root/distro/packages/multiprecision.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-18 01:06:24 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-18 01:07:31 +0100
commit1ffa7090b99dfd2f54fa883929c5e78d7852657a (patch)
tree1c8bd191e31212e172b3e9158408cccd571a5020 /distro/packages/multiprecision.scm
parent08ba7ff318720d926215de83daed0da628908ca3 (diff)
downloadguix-patches-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar
guix-patches-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar.gz
distro: Change the module name space to (gnu ...).
* distro: Rename to... * gnu: ... this. Update module names accordingly. * Makefile.am: Adjust accordingly. * po/POTFILES.in: Likewise. * distro.scm: Search for files under /gnu/packages instead of /distro/packages. * gnu/packages/base.scm (ld-wrapper-boot3): Likewise.
Diffstat (limited to 'distro/packages/multiprecision.scm')
-rw-r--r--distro/packages/multiprecision.scm124
1 files changed, 0 insertions, 124 deletions
diff --git a/distro/packages/multiprecision.scm b/distro/packages/multiprecision.scm
deleted file mode 100644
index 444c6103eb..0000000000
--- a/distro/packages/multiprecision.scm
+++ /dev/null
@@ -1,124 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (distro packages multiprecision)
- #:use-module (guix licenses)
- #:use-module (distro)
- #:use-module (distro packages m4)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix utils)
- #:use-module (guix build-system gnu))
-
-(define-public gmp
- (package
- (name "gmp")
- (version "5.1.0")
- (source (origin
- (method url-fetch)
- (uri
- ;; Note: this version is not available from GNU mirrors
- ;; because it was made with an Automake affected by
- ;; CVE-2012-3386.
- (string-append "ftp://ftp.gmplib.org/pub/gmp-"
- version "/gmp-" version ".tar.bz2"))
- (sha256
- (base32
- "15n7xxgasbxdch8ii8z9ic6fxc2ysk3q8iavf55abjp5iylspnfz"))))
- (build-system gnu-build-system)
- (native-inputs `(("m4" ,m4)))
- (arguments `(#:configure-flags
- '(;; Build a "fat binary", with routines for several
- ;; sub-architectures.
- "--enable-fat"
- "--enable-cxx")))
- (synopsis "GMP, the GNU multiple precision arithmetic library")
- (description
- "GMP is a free library for arbitrary precision arithmetic, operating on
-signed integers, rational numbers, and floating point numbers. There is no
-practical limit to the precision except the ones implied by the available
-memory in the machine GMP runs on. GMP has a rich set of functions, and the
-functions have a regular interface.
-
-The main target applications for GMP are cryptography applications and
-research, Internet security applications, algebra systems, computational
-algebra research, etc.
-
-GMP is carefully designed to be as fast as possible, both for small operands
-and for huge operands. The speed is achieved by using fullwords as the basic
-arithmetic type, by using fast algorithms, with highly optimised assembly
-code for the most common inner loops for a lot of CPUs, and by a general
-emphasis on speed.
-
-GMP is faster than any other bignum library. The advantage for GMP increases
-with the operand sizes for many operations, since GMP uses asymptotically
-faster algorithms.")
- (license lgpl3+)
- (home-page "http://gmplib.org/")))
-
-(define-public mpfr
- (package
- (name "mpfr")
- (version "3.1.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/mpfr/mpfr-" version
- ".tar.xz"))
- (sha256 (base32
- "0ym1ylcq803n52qrggxqmkz66gbn8ncc3ybawal31v5y5p1srma9"))))
- (build-system gnu-build-system)
- (inputs `(("gmp" ,gmp)))
- (synopsis "GNU MPFR, a library for multiple-precision floating-point
-arithmetic")
- (description
- "The GNU MPFR library is a C library for multiple-precision
-floating-point computations with correct rounding. MPFR is based on the GMP
-multiple-precision library.
-
-The main goal of MPFR is to provide a library for multiple-precision
-floating-point computation which is both efficient and has a well-defined
-semantics. It copies the good ideas from the ANSI/IEEE-754 standard for
-double-precision floating-point arithmetic (53-bit mantissa).")
- (license lgpl3+)
- (home-page "http://www.mpfr.org/")))
-
-(define-public mpc
- (package
- (name "mpc")
- (version "1.0.1")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "mirror://gnu/mpc/mpc-" version ".tar.gz"))
- (sha256 (base32
- "1zq0fidp1jii2j5k5n9hmx55a6wwid33gjzhimvxq9d5zrf82npd"))))
- (build-system gnu-build-system)
- (inputs `(("gmp" ,gmp)
- ("mpfr" ,mpfr)))
- (synopsis "GNU MPC, a library for multiprecision complex arithmetic
-with exact rounding")
- (description
- "GNU MPC is a C library for the arithmetic of complex numbers with
-arbitrarily high precision and correct rounding of the result. It extends
-the principles of the IEEE-754 standard for fixed precision real floating
-point numbers to complex numbers, providing well-defined semantics for
-every operation. At the same time, speed of operation at high precision
-is a major design goal. The library is built upon and follows the same
-principles as GNU MPFR.")
- (license lgpl3+)
- (home-page "http://mpc.multiprecision.org/")))