summaryrefslogtreecommitdiff
path: root/distro/packages/libidn.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-18 01:06:24 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-18 01:07:31 +0100
commit1ffa7090b99dfd2f54fa883929c5e78d7852657a (patch)
tree1c8bd191e31212e172b3e9158408cccd571a5020 /distro/packages/libidn.scm
parent08ba7ff318720d926215de83daed0da628908ca3 (diff)
downloadguix-patches-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar
guix-patches-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar.gz
distro: Change the module name space to (gnu ...).
* distro: Rename to... * gnu: ... this. Update module names accordingly. * Makefile.am: Adjust accordingly. * po/POTFILES.in: Likewise. * distro.scm: Search for files under /gnu/packages instead of /distro/packages. * gnu/packages/base.scm (ld-wrapper-boot3): Likewise.
Diffstat (limited to 'distro/packages/libidn.scm')
-rw-r--r--distro/packages/libidn.scm51
1 files changed, 0 insertions, 51 deletions
diff --git a/distro/packages/libidn.scm b/distro/packages/libidn.scm
deleted file mode 100644
index dbae143b3a..0000000000
--- a/distro/packages/libidn.scm
+++ /dev/null
@@ -1,51 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (distro packages libidn)
- #:use-module (distro)
- #:use-module (guix licenses)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu))
-
-(define-public libidn
- (package
- (name "libidn")
- (version "1.26")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/libidn/libidn-" version
- ".tar.gz"))
- (sha256 (base32
- "0g657kv60rh486m7bwyp5k24ljmym4wnb8nmk6d3i3qgr1qlqbqa"))))
- (build-system gnu-build-system)
-;; FIXME: No Java and C# libraries are currently built.
- (synopsis "GNU Libidn, a library to encode and decode internationalised domain names")
- (description
- "GNU Libidn is a fully documented implementation of the Stringprep,
-Punycode and IDNA specifications. Libidn's purpose is to encode and decode
-internationalised domain names.
-
-The library contains a generic Stringprep implementation. Profiles for
-Nameprep, iSCSI, SASL, XMPP and Kerberos V5 are included. Punycode and
-ASCII Compatible Encoding (ACE) via IDNA are supported. A mechanism to
-define Top-Level Domain (TLD) specific validation tables, and to compare
-strings against those tables, is included.
-Default tables for some TLDs are also included.")
- (license lgpl2.1+)
- (home-page "http://www.gnu.org/software/libidn/")))