summaryrefslogtreecommitdiff
path: root/distro/packages/bash.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-12-21 22:31:25 +0100
committerLudovic Courtès <ludo@gnu.org>2012-12-21 22:31:25 +0100
commitc089511288820cfb3efc5295e572be24aa83f068 (patch)
treeece62d1d06ee146feb59f60fe5c4d307542205cc /distro/packages/bash.scm
parent8722e80e82f6b2ca326b20a4b3179ed25115ce4f (diff)
downloadguix-patches-c089511288820cfb3efc5295e572be24aa83f068.tar
guix-patches-c089511288820cfb3efc5295e572be24aa83f068.tar.gz
build-system/gnu: Patch shebangs in all the source; patch SHELL in makefiles.
* guix/build/utils.scm (call-with-ascii-input-file): New procedure. (patch-shebang): Use it. (patch-makefile-SHELL): New procedure. * guix/build/gnu-build-system.scm (patch-source-shebangs): Patch all the files, not just executables; remove `po/Makefile.in.in' patching. (patch-generated-files): Rename to... (patch-generated-file-shebangs): ... this. Patch executables and makefiles. (%standard-phases): Adjust accordingly. * distro/packages/autotools.scm (libtool): Remove call to `patch-shebang'. * distro/packages/base.scm (gcc-4.7): Likewise. (guile-final): Remove hack to skip `test-command-line-encoding2'. * distro/packages/bash.scm (bash): Remove `pre-configure-phase'. * distro/packages/readline.scm (readline): Likewise. * distro/packages/ncurses.scm (ncurses): Remove `pre-install-phase'.
Diffstat (limited to 'distro/packages/bash.scm')
-rw-r--r--distro/packages/bash.scm16
1 files changed, 3 insertions, 13 deletions
diff --git a/distro/packages/bash.scm b/distro/packages/bash.scm
index c2022fcf95..f32293d82f 100644
--- a/distro/packages/bash.scm
+++ b/distro/packages/bash.scm
@@ -33,13 +33,6 @@
"-DNON_INTERACTIVE_LOGIN_SHELLS"
"-DSSH_SOURCE_BASHRC")
" "))
- (pre-configure-phase
- '(lambda* (#:key inputs #:allow-other-keys)
- ;; Use the right shell for makefiles.
- (let ((bash (assoc-ref inputs "bash")))
- (substitute* "configure"
- (("MAKE_SHELL=[^ ]+")
- (format #f "MAKE_SHELL=~a/bin/bash" bash))))))
(post-install-phase
'(lambda* (#:key outputs #:allow-other-keys)
;; Add a `bash' -> `sh' link.
@@ -80,12 +73,9 @@
;; for now.
#:tests? #f
- #:phases (alist-cons-before
- 'configure 'pre-configure
- ,pre-configure-phase
- (alist-cons-after 'install 'post-install
- ,post-install-phase
- %standard-phases))))
+ #:phases (alist-cons-after 'install 'post-install
+ ,post-install-phase
+ %standard-phases)))
(synopsis "GNU Bourne-Again Shell")
(description
"Bash is the shell, or command language interpreter, that will appear in