summaryrefslogtreecommitdiff
path: root/distro/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-12-21 22:31:25 +0100
committerLudovic Courtès <ludo@gnu.org>2012-12-21 22:31:25 +0100
commitc089511288820cfb3efc5295e572be24aa83f068 (patch)
treeece62d1d06ee146feb59f60fe5c4d307542205cc /distro/packages/base.scm
parent8722e80e82f6b2ca326b20a4b3179ed25115ce4f (diff)
downloadguix-patches-c089511288820cfb3efc5295e572be24aa83f068.tar
guix-patches-c089511288820cfb3efc5295e572be24aa83f068.tar.gz
build-system/gnu: Patch shebangs in all the source; patch SHELL in makefiles.
* guix/build/utils.scm (call-with-ascii-input-file): New procedure. (patch-shebang): Use it. (patch-makefile-SHELL): New procedure. * guix/build/gnu-build-system.scm (patch-source-shebangs): Patch all the files, not just executables; remove `po/Makefile.in.in' patching. (patch-generated-files): Rename to... (patch-generated-file-shebangs): ... this. Patch executables and makefiles. (%standard-phases): Adjust accordingly. * distro/packages/autotools.scm (libtool): Remove call to `patch-shebang'. * distro/packages/base.scm (gcc-4.7): Likewise. (guile-final): Remove hack to skip `test-command-line-encoding2'. * distro/packages/bash.scm (bash): Remove `pre-configure-phase'. * distro/packages/readline.scm (readline): Likewise. * distro/packages/ncurses.scm (ncurses): Remove `pre-install-phase'.
Diffstat (limited to 'distro/packages/base.scm')
-rw-r--r--distro/packages/base.scm31
1 files changed, 5 insertions, 26 deletions
diff --git a/distro/packages/base.scm b/distro/packages/base.scm
index 0a937486a4..0289b6c688 100644
--- a/distro/packages/base.scm
+++ b/distro/packages/base.scm
@@ -428,9 +428,6 @@ BFD (Binary File Descriptor) library, `gprof', `nm', `strip', etc.")
~a~%"
libc line))))
- ;; Adjust hard-coded #!/bin/sh.
- (patch-shebang "gcc/exec-tool.in")
-
;; Don't retain a dependency on the build-time sed.
(substitute* "fixincludes/fixincl.x"
(("static char const sed_cmd_z\\[\\] =.*;")
@@ -967,29 +964,11 @@ store.")
;; FIXME: The Libtool used here, specifically its `bin/libtool' script,
;; holds a dependency on the bootstrap Binutils. Use multiple outputs for
;; Libtool, so that that dependency is isolated in the "bin" output.
- (let ((guile (package (inherit guile-2.0/fixed)
- (arguments
- (substitute-keyword-arguments
- (package-arguments guile-2.0/fixed)
- ((#:phases phases)
- `(alist-cons-before
- 'patch-source-shebangs 'delete-encoded-test
- (lambda* (#:key inputs #:allow-other-keys)
- ;; %BOOTSTRAP-GUILE doesn't know about encodings other
- ;; than UTF-8. That test declares an ISO-8859-1
- ;; encoding, which prevents `patch-shebang' from
- ;; working, so skip it.
- (call-with-output-file
- "test-suite/standalone/test-command-line-encoding2"
- (lambda (p)
- (format p "#!~a/bin/bash\nexit 77"
- (assoc-ref inputs "bash")))))
- ,phases)))))))
- (package-with-bootstrap-guile
- (package-with-explicit-inputs guile
- %boot4-inputs
- (current-source-location)
- #:guile %bootstrap-guile))))
+ (package-with-bootstrap-guile
+ (package-with-explicit-inputs guile-2.0/fixed
+ %boot4-inputs
+ (current-source-location)
+ #:guile %bootstrap-guile)))
(define-public ld-wrapper
;; The final `ld' wrapper, which uses the final Guile.