summaryrefslogtreecommitdiff
path: root/distro/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-09-01 11:52:52 +0200
committerLudovic Courtès <ludo@gnu.org>2012-09-01 11:52:52 +0200
commit9dd036f35c9a825c30aecc9eb3a3f6266481cfe3 (patch)
treeaf3bc96172584ac7aeef863ad9b4c04bf04af887 /distro/base.scm
parent6dd7787c391884f978a11a6673fb934fdb0e6ef1 (diff)
downloadguix-patches-9dd036f35c9a825c30aecc9eb3a3f6266481cfe3.tar
guix-patches-9dd036f35c9a825c30aecc9eb3a3f6266481cfe3.tar.gz
distro: m4: Add patch to allow builds with glibc 2.16+.
* distro/base.scm (m4): Use `m4-gets-undeclared.patch'. * distro/patches/m4-gets-undeclared.patch: New file. * Makefile.am (dist_patch_DATA): Add it.
Diffstat (limited to 'distro/base.scm')
-rw-r--r--distro/base.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/distro/base.scm b/distro/base.scm
index 949cb571b1..c3a6846581 100644
--- a/distro/base.scm
+++ b/distro/base.scm
@@ -389,14 +389,17 @@ are expected to exist on every operating system.")
"i686-sunos")))
#:patches (list (assoc-ref %build-inputs "patch/s_isdir")
(assoc-ref %build-inputs
- "patch/readlink-EINVAL"))))
+ "patch/readlink-EINVAL")
+ (assoc-ref %build-inputs "patch/gets"))))
((system cross-system)
`(#:patches (list (assoc-ref %build-inputs "patch/s_isdir")
(assoc-ref %build-inputs
- "patch/readlink-EINVAL"))))))
+ "patch/readlink-EINVAL")
+ (assoc-ref %build-inputs "patch/gets"))))))
(inputs `(("patch/s_isdir" ,(search-patch "m4-s_isdir.patch"))
("patch/readlink-EINVAL"
- ,(search-patch "m4-readlink-EINVAL.patch"))))
+ ,(search-patch "m4-readlink-EINVAL.patch"))
+ ("patch/gets" ,(search-patch "m4-gets-undeclared.patch"))))
(description "GNU M4, a macro processor")
(long-description
"GNU M4 is an implementation of the traditional Unix macro processor. It