summaryrefslogtreecommitdiff
path: root/build-aux
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-10-17 21:44:25 +0200
committerLudovic Courtès <ludo@gnu.org>2012-10-17 23:25:25 +0200
commitac5aa28889ac3a535f8cfdd71047c9aa10b1959d (patch)
tree24498549369142b80528fa21b2d12629eb8432e6 /build-aux
parent9735a7b6eaccf248d91e1f3c17446b2fac41ec9a (diff)
downloadguix-patches-ac5aa28889ac3a535f8cfdd71047c9aa10b1959d.tar
guix-patches-ac5aa28889ac3a535f8cfdd71047c9aa10b1959d.tar.gz
distro: Use our own pre-built Guile to bootstrap.
* distro/packages/base.scm (%bootstrap-guile): Build from a tarball containing a pre-built Guile. * distro.scm (%bootstrap-binaries-directory): New variable. (search-bootstrap-binary): New procedure. * Makefile.am (bootstrapdir, bootstrap_x86_64_linuxdir, dist_bootstrap_x86_64_linux_DATA, DISTCLEANFILES, DOWNLOAD_FILE): New variables. (distro/packages/bootstrap/x86_64-linux/guile-bootstrap-2.0.6.tar.xz): New rule. (EXTRA_DIST): Add `build-aux/download.scm'. (.scm.go): Define the `DISTRO_BOOTSTRAP_DIRECTORY' and `DISTRO_INSTALLED_BOOTSTRAP_DIRECTORY' environment variables. * pre-inst-env.in: Define `DISTRO_BOOTSTRAP_DIRECTORY'. * build-aux/download.scm: New file. * distro/packages/bootstrap/x86_64-linux/{bash, mkdir, tar, xz}: New files.
Diffstat (limited to 'build-aux')
-rw-r--r--build-aux/download.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/build-aux/download.scm b/build-aux/download.scm
new file mode 100644
index 0000000000..9da39155ea
--- /dev/null
+++ b/build-aux/download.scm
@@ -0,0 +1,57 @@
+;;; Guix --- Nix package management from Guile. -*- coding: utf-8 -*-
+;;; Copyright (C) 2012 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of Guix.
+;;;
+;;; Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Guix. If not, see <http://www.gnu.org/licenses/>.
+
+;;;
+;;; Download a binary file from an external source.
+;;;
+
+(use-modules (ice-9 match)
+ (web uri)
+ (web client)
+ (rnrs io ports)
+ (srfi srfi-11)
+ (guix utils))
+
+(define %url-base
+ "http://www.fdn.fr/~lcourtes/software/guix/packages")
+
+(define (file-name->uri file)
+ "Return the URI for FILE."
+ (match (string-tokenize file (char-set-complement (char-set #\/)))
+ ((_ ... system basename)
+ (string->uri (string-append %url-base "/" system "/" basename)))))
+
+(match (command-line)
+ ((_ file expected-hash)
+ (let ((uri (file-name->uri file)))
+ (format #t "downloading file `~a' from `~a'...~%"
+ file (uri->string uri))
+ (let*-values (((resp data) (http-get uri #:decode-body? #f))
+ ((hash) (bytevector->base16-string (sha256 data)))
+ ((part) (string-append file ".part")))
+ (if (string=? expected-hash hash)
+ (begin
+ (call-with-output-file part
+ (lambda (port)
+ (put-bytevector port data)))
+ (rename-file part file))
+ (begin
+ (format (current-error-port)
+ "file at `~a' has SHA256 ~a; expected ~a~%"
+ (uri->string uri) hash expected-hash)
+ (exit 1)))))))