summaryrefslogtreecommitdiff
path: root/build-aux/hydra/demo-os.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-04-05 22:40:16 +0200
committerLudovic Courtès <ludo@gnu.org>2014-04-05 22:40:16 +0200
commit731b996255fb699cd91699f6cd22de41ebafcdcd (patch)
tree749b63309998feb1bf27033fe1dd28ff2ed35e15 /build-aux/hydra/demo-os.scm
parent512314d738754eeb513a0d1b8074f635ab4f2f06 (diff)
downloadguix-patches-731b996255fb699cd91699f6cd22de41ebafcdcd.tar
guix-patches-731b996255fb699cd91699f6cd22de41ebafcdcd.tar.gz
hydra: Add 'qemu-image' job.
* build-aux/hydra/demo-os.scm: New file. * Makefile.am (EXTRA_DIST): Add it. * build-aux/hydra/gnu-system.scm (qemu-jobs): New procedure. (hydra-jobs): Use it. * guix/scripts/system.scm (read-operating-system): Export.
Diffstat (limited to 'build-aux/hydra/demo-os.scm')
-rw-r--r--build-aux/hydra/demo-os.scm62
1 files changed, 62 insertions, 0 deletions
diff --git a/build-aux/hydra/demo-os.scm b/build-aux/hydra/demo-os.scm
new file mode 100644
index 0000000000..eaf79584b6
--- /dev/null
+++ b/build-aux/hydra/demo-os.scm
@@ -0,0 +1,62 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+
+;;;
+;;; This file defines an operating system configuration for the demo virtual
+;;; machine images that we build.
+;;;
+
+(use-modules (gnu packages emacs)
+ (gnu packages xorg)
+ (gnu packages base)
+ (gnu packages admin)
+ (gnu packages guile)
+ (gnu packages bash)
+ (gnu packages linux)
+ (gnu packages less)
+ (gnu packages tor)
+
+ (gnu system shadow) ; 'user-account'
+ (gnu services base)
+ (gnu services networking)
+ (gnu services xorg))
+
+(operating-system
+ (host-name "gnu")
+ (timezone "Europe/Paris")
+ (locale "en_US.UTF-8")
+ (users (list (user-account
+ (name "guest")
+ (uid 1000) (gid 100)
+ (comment "Guest of GNU")
+ (home-directory "/home/guest"))))
+ (services (cons* (slim-service #:auto-login? #f
+ #:default-user "root")
+
+ ;; QEMU networking settings.
+ (static-networking-service "eth0" "10.0.2.10"
+ #:name-servers '("10.0.2.3")
+ #:gateway "10.0.2.2")
+
+ %base-services))
+ (packages (list bash coreutils findutils grep sed
+ procps psmisc less
+ guile-2.0 dmd util-linux inetutils
+ xterm emacs
+ tor)))