summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-04 21:44:42 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-04 21:46:14 +0100
commit9d9e64508186e5f9efbe45302134cd709b25e47b (patch)
tree94e81999e707f8deaac3f8f047c64a3b21a5ea24 /Makefile.am
parent59b775cca97813a24e529171606e967b61e80877 (diff)
downloadguix-patches-9d9e64508186e5f9efbe45302134cd709b25e47b.tar
guix-patches-9d9e64508186e5f9efbe45302134cd709b25e47b.tar.gz
distro: Go for one module per package.
The alternative, which was to use one module per category, would probably not scale well. First, because many packages could fall into several categories (does GnuTLS go into "networking", "security", or "libraries"?). Second, because that could easily lead to circular dependencies among modules ("security" and "networking" depend on each other, etc.) * distro/packages/databases.scm: Rename to... * distro/packages/recutils.scm: ... this. * distro/packages/typesetting.scm: Rename to... * distro/packages/lout.scm: ... this. * Makefile.am (MODULES): Adjust accordingly. * po/POTFILES.in: Likewise.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 8403081cb7..9b0240a95f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -43,10 +43,10 @@ MODULES = \
guix.scm \
distro.scm \
distro/packages/base.scm \
- distro/packages/databases.scm \
distro/packages/guile.scm \
distro/packages/ld-wrapper.scm \
- distro/packages/typesetting.scm
+ distro/packages/lout.scm \
+ distro/packages/recutils.scm
GOBJECTS = $(MODULES:%.scm=%.go) guix/config.go