summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2017-02-17 13:28:16 +0300
committerAlex Kost <alezost@gmail.com>2017-02-27 16:44:58 +0300
commit7994250fdb7ce786a72278554d85fccb6d152e73 (patch)
tree93e7d5a8215491089502846f3634266efe5130e1 /Makefile.am
parent96eaa55ffb9877c319df09d158fca31034d8f0a2 (diff)
downloadguix-patches-7994250fdb7ce786a72278554d85fccb6d152e73.tar
guix-patches-7994250fdb7ce786a72278554d85fccb6d152e73.tar.gz
gnu: linux: Move configuration files to "aux-files".
* gnu/packages/linux-libre-4.1-i686.conf: Rename to... * gnu/packages/aux-files/linux-libre/4.1-i686.conf: ... this. * gnu/packages/linux-libre-4.1-x86_64.conf: Rename to... * gnu/packages/aux-files/linux-libre/4.1-x86_64.conf: ... this. * gnu/packages/linux-libre-4.4-i686.conf: Rename to... * gnu/packages/aux-files/linux-libre/4.4-i686.conf: ... this. * gnu/packages/linux-libre-4.4-x86_64.conf: Rename to... * gnu/packages/aux-files/linux-libre/4.4-x86_64.conf: ... this. * gnu/packages/linux-libre-4.9-i686.conf: Rename to... * gnu/packages/aux-files/linux-libre/4.9-i686.conf: ... this. * gnu/packages/linux-libre-4.9-x86_64.conf: Rename to... * gnu/packages/aux-files/linux-libre/4.9-x86_64.conf: ... this. * gnu/packages/linux-libre-4.10-i686.conf: Rename to... * gnu/packages/aux-files/linux-libre/4.10-i686.conf: ... this. * gnu/packages/linux-libre-4.10-x86_64.conf: Rename to... * gnu/packages/aux-files/linux-libre/4.10-x86_64.conf: ... this. * gnu/packages/linux.scm (kernel-config): Use 'search-auxiliary-file' to find configuration files. * Makefile.am (KCONFIGS): Rename to... (AUX_FILES): ... this. Adjust accordingly.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 12 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index 0de2e0987c..2e048f99ae 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
# GNU Guix --- Functional package management for GNU
# Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
# Copyright © 2013 Andreas Enge <andreas@enge.fr>
-# Copyright © 2015 Alex Kost <alezost@gmail.com>
+# Copyright © 2015, 2017 Alex Kost <alezost@gmail.com>
# Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
# Copyright © 2016, 2017 Mark H Weaver <mhw@netris.org>
#
@@ -196,16 +196,16 @@ endif BUILD_DAEMON_OFFLOAD
# Internal modules with test suite support.
dist_noinst_DATA = guix/tests.scm guix/tests/http.scm
-# Linux-Libre configurations.
-KCONFIGS = \
- gnu/packages/linux-libre-4.10-i686.conf \
- gnu/packages/linux-libre-4.10-x86_64.conf \
- gnu/packages/linux-libre-4.9-i686.conf \
- gnu/packages/linux-libre-4.9-x86_64.conf \
- gnu/packages/linux-libre-4.4-i686.conf \
- gnu/packages/linux-libre-4.4-x86_64.conf \
- gnu/packages/linux-libre-4.1-i686.conf \
- gnu/packages/linux-libre-4.1-x86_64.conf
+# Auxiliary files for packages.
+AUX_FILES = \
+ gnu/packages/aux-files/linux-libre/4.10-i686.conf \
+ gnu/packages/aux-files/linux-libre/4.10-x86_64.conf \
+ gnu/packages/aux-files/linux-libre/4.9-i686.conf \
+ gnu/packages/aux-files/linux-libre/4.9-x86_64.conf \
+ gnu/packages/aux-files/linux-libre/4.4-i686.conf \
+ gnu/packages/aux-files/linux-libre/4.4-x86_64.conf \
+ gnu/packages/aux-files/linux-libre/4.1-i686.conf \
+ gnu/packages/aux-files/linux-libre/4.1-x86_64.conf
# Templates, examples.
EXAMPLES = \
@@ -216,7 +216,7 @@ EXAMPLES = \
GOBJECTS = $(MODULES:%.scm=%.go) guix/config.go $(dist_noinst_DATA:%.scm=%.go)
nobase_dist_guilemodule_DATA = \
- $(MODULES) $(KCONFIGS) $(EXAMPLES) \
+ $(MODULES) $(AUX_FILES) $(EXAMPLES) \
$(MISC_DISTRO_FILES)
nobase_nodist_guilemodule_DATA = $(GOBJECTS) guix/config.scm