summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-03-14 15:11:03 +0100
committerLudovic Courtès <ludo@gnu.org>2017-03-14 17:57:27 +0100
commit6b63c43e0661406bf9e8c4c54f517744fc2ffdb3 (patch)
tree5589fbfa37c20e5210a2ee6921b2ff32b653cb7c /Makefile.am
parent9b05ccfedd9945ca09103e1e9557d5988b4815d5 (diff)
downloadguix-patches-6b63c43e0661406bf9e8c4c54f517744fc2ffdb3.tar
guix-patches-6b63c43e0661406bf9e8c4c54f517744fc2ffdb3.tar.gz
pack: Add '--localstatedir' option.
* guix/scripts/pack.scm (self-contained-tarball): Add #:localstatedir? parameter and honor it. (%options, show-help): Add '--localstatedir'. (guix-pack): Honor it. * gnu/build/install.scm (populate-single-profile-directory): Add #:register? parameter and honor it. * doc/guix.texi (Binary Installation): Use '--localstatedir' in example. (Invoking guix pack): Document it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2684d66bf1..23171ae837 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -488,7 +488,7 @@ AM_DISTCHECK_CONFIGURE_FLAGS = \
guix-binary.%.tar.xz:
$(AM_V_GEN)GUIX_PACKAGE_PATH= \
tarball=`$(top_builddir)/pre-inst-env guix pack -C xz \
- -s "$*" guix` ; \
+ -s "$*" --localstatedir guix` ; \
cp "$$tarball" "$@.tmp" ; mv "$@.tmp" "$@"