summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-03-13 23:08:49 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-03-13 23:08:49 +0200
commit3f9543aee1e49001d0f80542dd71ba73c44787c7 (patch)
tree50ee1bdd53b1e5ec69cb8655f23da79c332dde1e /Makefile.am
parent864a9590ad948df09f2ad6e9e929608a7587a5f7 (diff)
parenta71c863834448e2645518b31b60a96ef488dd761 (diff)
downloadguix-patches-3f9543aee1e49001d0f80542dd71ba73c44787c7.tar
guix-patches-3f9543aee1e49001d0f80542dd71ba73c44787c7.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index cda49bd9ec..2443f6891f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -139,6 +139,7 @@ MODULES = \
guix/scripts/package.scm \
guix/scripts/gc.scm \
guix/scripts/hash.scm \
+ guix/scripts/pack.scm \
guix/scripts/pull.scm \
guix/scripts/substitute.scm \
guix/scripts/authenticate.scm \
@@ -398,7 +399,6 @@ EXTRA_DIST = \
build-aux/check-available-binaries.scm \
build-aux/check-final-inputs-self-contained.scm \
build-aux/download.scm \
- build-aux/make-binary-tarball.scm \
build-aux/generate-authors.scm \
build-aux/test-driver.scm \
build-aux/run-system-tests.scm \
@@ -487,9 +487,10 @@ AM_DISTCHECK_CONFIGURE_FLAGS = \
# The self-contained tarball.
guix-binary.%.tar.xz:
- $(AM_V_GEN)GUIX_PACKAGE_PATH= \
- $(top_builddir)/pre-inst-env "$(GUILE)" \
- "$(top_srcdir)/build-aux/make-binary-tarball.scm" "$*" "$@"
+ $(AM_V_GEN)GUIX_PACKAGE_PATH= \
+ tarball=`$(top_builddir)/pre-inst-env guix pack -C xz \
+ -s "$*" guix` ; \
+ cp "$$tarball" "$@.tmp" ; mv "$@.tmp" "$@"
dist-hook: sync-descriptions gen-ChangeLog gen-AUTHORS