summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-10-12 15:26:01 +0200
committerLudovic Courtès <ludo@gnu.org>2016-10-12 23:35:43 +0200
commit69e7322fdccaf28aad644ffaf9dedb7f21327f49 (patch)
treea09d3d572f7935979fa3a524bfbc56d5a3560bd6 /Makefile.am
parent402bb3b9f7eaaa66f2652fda2d9e0d2e34cf59f8 (diff)
downloadguix-patches-69e7322fdccaf28aad644ffaf9dedb7f21327f49.tar
guix-patches-69e7322fdccaf28aad644ffaf9dedb7f21327f49.tar.gz
build: Make 'assert-no-store-file-names' effective.
Lack of '-E' made it useless. * Makefile.am (assert-no-store-file-names): Pass '-E' to grep. Add '--exclude' and '--exclude-dir' flags.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7f2281cfa4..908eaf6ec0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -495,7 +495,10 @@ gen-AUTHORS:
# Make sure we're not shipping a file that embeds a local /gnu/store file name.
assert-no-store-file-names:
$(AM_V_at)if grep -r --exclude=*.texi --exclude=*.info \
- "$(storedir)/[a-z0-9]{32}-" $(distdir) ; \
+ --exclude=*.info-[0-9] --exclude=*.dot \
+ --exclude=*.eps --exclude-dir=bootstrap \
+ --exclude=guix-prettify.el \
+ -E "$(storedir)/[a-z0-9]{32}-" $(distdir) ; \
then \
echo "error: store file names embedded in the distribution" >&2 ; \
exit 1 ; \