summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-10-26 19:10:37 +0200
committerLudovic Courtès <ludo@gnu.org>2012-10-26 19:10:37 +0200
commitd25468bcb2772ac10efb2ae7035250af20e19c85 (patch)
tree1f5f88b240cddda5b013bc798137abb3f2f07164 /Makefile.am
parentfc95fdaebe5f99ceb6ad0ea5fe0d8ea44ba92aab (diff)
downloadguix-patches-d25468bcb2772ac10efb2ae7035250af20e19c85.tar
guix-patches-d25468bcb2772ac10efb2ae7035250af20e19c85.tar.gz
distro: Add i686-linux port.
* distro/packages/bootstrap/i686-linux/bash, distro/packages/bootstrap/i686-linux/mkdir, distro/packages/bootstrap/i686-linux/tar, distro/packages/bootstrap/i686-linux/xz: New files. * distro/packages/base.scm (%bootstrap-coreutils&co, %bootstrap-binutils, %bootstrap-glibc, %bootstrap-gcc): Add hashes of the i686-linux tarballs. * Makefile.am (bootstrap_i686_linuxdir, dist_bootstrap_i686_linux_DATA, nodist_bootstrap_i686_linux_DATA): New variables (DISTCLEANFILES): Add $(nodist_bootstrap_i686_linux_DATA). (distro/packages/bootstrap/i686-linux/guile-bootstrap-2.0.6.tar.xz): New rule.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 623a07a7f1..35c477ea6a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,6 +66,7 @@ dist_patch_DATA = \
bootstrapdir = $(pkgdatadir)/bootstrap
bootstrap_x86_64_linuxdir = $(bootstrapdir)/x86_64-linux
+bootstrap_i686_linuxdir = $(bootstrapdir)/i686-linux
dist_bootstrap_x86_64_linux_DATA = \
distro/packages/bootstrap/x86_64-linux/bash \
@@ -73,12 +74,22 @@ dist_bootstrap_x86_64_linux_DATA = \
distro/packages/bootstrap/x86_64-linux/tar \
distro/packages/bootstrap/x86_64-linux/xz
+dist_bootstrap_i686_linux_DATA = \
+ distro/packages/bootstrap/i686-linux/bash \
+ distro/packages/bootstrap/i686-linux/mkdir \
+ distro/packages/bootstrap/i686-linux/tar \
+ distro/packages/bootstrap/i686-linux/xz
+
# Big bootstrap binaries are not included in the tarball. Instead, they
# are downloaded.
nodist_bootstrap_x86_64_linux_DATA = \
distro/packages/bootstrap/x86_64-linux/guile-bootstrap-2.0.6.tar.xz
+nodist_bootstrap_i686_linux_DATA = \
+ distro/packages/bootstrap/i686-linux/guile-bootstrap-2.0.6.tar.xz
-DISTCLEANFILES = $(nodist_bootstrap_x86_64_linux_DATA)
+DISTCLEANFILES = \
+ $(nodist_bootstrap_x86_64_linux_DATA) \
+ $(nodist_bootstrap_i686_linux_DATA)
# Method to download a file from an external source.
DOWNLOAD_FILE = \
@@ -88,6 +99,8 @@ DOWNLOAD_FILE = \
distro/packages/bootstrap/x86_64-linux/guile-bootstrap-2.0.6.tar.xz: guix/utils.go
$(DOWNLOAD_FILE) "$@" "0467a82cbe4136f60a79eb4176011bf88cf28ea19c9ad9defa365811ff8e11cf"
+distro/packages/bootstrap/i686-linux/guile-bootstrap-2.0.6.tar.xz: guix/utils.go
+ $(DOWNLOAD_FILE) "$@" "93b537766dfab3ad287143523751e3ec02dd32d3ccaf88ad2d31c63158f342ee"
nobase_nodist_guilemodule_DATA = $(GOBJECTS)