summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-08-01 22:52:54 +0200
committerLudovic Courtès <ludo@gnu.org>2016-08-01 22:52:54 +0200
commitd92e23dc9dcc90f2fbf2c956201ae194d6d31742 (patch)
tree189297b9fbfcf85e73e25c124575277f080ab00c /Makefile.am
parent23431ad9d56ca833442fe649092883a2e4240d6b (diff)
downloadguix-patches-d92e23dc9dcc90f2fbf2c956201ae194d6d31742.tar
guix-patches-d92e23dc9dcc90f2fbf2c956201ae194d6d31742.tar.gz
build: Set XDG_CACHE_HOME to avoid loading stale .go files.
Fixes <http://bugs.gnu.org/24120>. Reported by myglc2 <myglc2@gmail.com>. * Makefile.am (make-go): Set XDG_CACHE_HOME.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 543b10175b..8bae85e144 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -389,11 +389,13 @@ CLEANFILES = \
# there that are newer than the local .scm files (for instance because the
# user ran 'make install' recently). When that happens, we end up loading
# those previously-installed .go files, which may be stale, thereby breaking
-# the whole thing.
+# the whole thing. Likewise, set 'XDG_CACHE_HOME' to avoid loading possibly
+# stale files from ~/.cache/guile/ccache.
%.go: make-go ; @:
make-go: $(MODULES) guix/config.scm guix/tests.scm
$(AM_V_at)echo "Compiling Scheme modules..." ; \
unset GUILE_LOAD_COMPILED_PATH ; \
+ XDG_CACHE_HOME=/nowhere \
host=$(host) srcdir="$(top_srcdir)" \
$(top_builddir)/pre-inst-env \
$(GUILE) -L "$(top_builddir)" -L "$(top_srcdir)" \