summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-10-31 23:27:51 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-01 00:52:46 +0100
commit97298ffae9fef6260bc812fffb01972736bc0ab4 (patch)
tree5497c0f1bc4fd7fb77079b68e060b17a98a4eea4 /Makefile.am
parent073c34d72f94adf6c4c307239b1de0d14bdb60f3 (diff)
downloadguix-patches-97298ffae9fef6260bc812fffb01972736bc0ab4.tar
guix-patches-97298ffae9fef6260bc812fffb01972736bc0ab4.tar.gz
build: Add unit test for the `guix-build' command.
* tests/guix-build.sh: New file. * Makefile.am (TESTS): Add it. (LOG_COMPILER): Rename to... (SCM_LOG_COMPILER): ... this. Move flags to... (AM_SCM_LOG_FLAGS): ... this. (TEST_EXTENSIONS, SH_LOG_COMPILER, AM_SH_LOG_FLAGS): New variables.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index daec24460a..d3a3dbf69a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -119,11 +119,16 @@ TESTS = \
tests/utils.scm \
tests/build-utils.scm \
tests/packages.scm \
- tests/union.scm
+ tests/union.scm \
+ tests/guix-build.sh
-LOG_COMPILER = \
- $(top_builddir)/pre-inst-env \
- $(GUILE) --no-auto-compile -L "$(top_srcdir)"
+TEST_EXTENSIONS = .scm .sh
+
+SCM_LOG_COMPILER = $(top_builddir)/pre-inst-env $(GUILE)
+AM_SCM_LOG_FLAGS = --no-auto-compile -L "$(top_srcdir)"
+
+SH_LOG_COMPILER = $(top_builddir)/pre-inst-env $(SHELL)
+AM_SH_LOG_FLAGS = -x -e
EXTRA_DIST = \
HACKING \