summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-08-26 18:35:14 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-08-26 18:35:14 +0200
commit17dddeeee560527a8f30d37761949d658056cb09 (patch)
tree15b0b19c55787f556eb9b42c28d173bddc5435db /Makefile.am
parent331a09654eb7e9f6212b7e8469077fa7393e8b11 (diff)
parent6a9581741e4ee81226aeb2f1c997df76670a6aab (diff)
downloadguix-patches-17dddeeee560527a8f30d37761949d658056cb09.tar
guix-patches-17dddeeee560527a8f30d37761949d658056cb09.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 13 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index 31784adfff..9c38c2f83c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -109,8 +109,6 @@ MODULES = \
guix/cache.scm \
guix/cve.scm \
guix/workers.scm \
- guix/zlib.scm \
- guix/lzlib.scm \
guix/build-system.scm \
guix/build-system/android-ndk.scm \
guix/build-system/ant.scm \
@@ -333,6 +331,14 @@ dist_noinst_DATA = \
AUX_FILES = \
gnu/packages/aux-files/chromium/master-preferences.json \
gnu/packages/aux-files/emacs/guix-emacs.el \
+ gnu/packages/aux-files/linux-libre/5.8-arm.conf \
+ gnu/packages/aux-files/linux-libre/5.8-arm64.conf \
+ gnu/packages/aux-files/linux-libre/5.8-i686.conf \
+ gnu/packages/aux-files/linux-libre/5.8-x86_64.conf \
+ gnu/packages/aux-files/linux-libre/5.7-arm.conf \
+ gnu/packages/aux-files/linux-libre/5.7-arm64.conf \
+ gnu/packages/aux-files/linux-libre/5.7-i686.conf \
+ gnu/packages/aux-files/linux-libre/5.7-x86_64.conf \
gnu/packages/aux-files/linux-libre/5.4-arm.conf \
gnu/packages/aux-files/linux-libre/5.4-arm64.conf \
gnu/packages/aux-files/linux-libre/5.4-i686.conf \
@@ -423,11 +429,11 @@ SCM_TESTS = \
tests/import-utils.scm \
tests/inferior.scm \
tests/lint.scm \
- tests/lzlib.scm \
tests/modules.scm \
tests/monads.scm \
tests/nar.scm \
tests/networking.scm \
+ tests/offload.scm \
tests/opam.scm \
tests/openpgp.scm \
tests/packages.scm \
@@ -462,8 +468,7 @@ SCM_TESTS = \
tests/upstream.scm \
tests/utils.scm \
tests/uuid.scm \
- tests/workers.scm \
- tests/zlib.scm
+ tests/workers.scm
SH_TESTS = \
tests/guix-build.sh \
@@ -649,11 +654,10 @@ commit_v1_0_0 = 6298c3ffd9654d3231a6f25390b056483e8f407c
channel_intro_commit = 9edb3f66fd807b096b48283debdcddccfea34bad
channel_intro_signer = BBB0 2DDF 2CEA F6A8 0D1D E643 A2A0 6DF2 A33A 54FA
-# Authenticate the current Git checkout by checking signatures on every commit
-# starting from $(commit_v1_0_0).
-authenticate: guix/openpgp.go guix/git-authenticate.go guix/git.go
+# Authenticate the current Git checkout by checking signatures on every commit.
+authenticate:
$(AM_V_at)echo "Authenticating Git checkout..." ; \
- "$(top_builddir)/pre-inst-env" guix git authenticate \
+ guix git authenticate \
--cache-key=channels/guix --stats \
"$(channel_intro_commit)" "$(channel_intro_signer)"