summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAttila Lendvai <attila@lendvai.name>2021-12-21 22:56:10 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-12-22 10:53:19 +0100
commit9ebc9ca070a21ba0aeb3f61202a8071bb250ccc8 (patch)
treef29313e0c83112cf7aceeec893f1ee68135af78b /Makefile.am
parent5b8ae331f73d970e29566b82c9fe36aa0d77ccb7 (diff)
downloadguix-patches-9ebc9ca070a21ba0aeb3f61202a8071bb250ccc8.tar
guix-patches-9ebc9ca070a21ba0aeb3f61202a8071bb250ccc8.tar.gz
tests: Move keys into ./tests/keys/ and add a third ed25519 key.
The third key will be used in an upcoming commit. Rename public keys to .pub. * guix/tests/gnupg.scm (%ed25519-3-public-key-file): New variable. (%ed25519-3-secret-key-file): New variable. (%ed25519-2-public-key-file): Renamed from %ed25519bis-public-key-file. (%ed25519-2-secret-key-file): Renamed from %ed25519bis-secret-key-file. * tests/keys/ed25519-3.key: New file. * tests/keys/ed25519-3.sec: New file. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 11 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index c4ccee65f1..d39052521b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -653,16 +653,18 @@ EXTRA_DIST += \
build-aux/update-guix-package.scm \
build-aux/update-NEWS.scm \
tests/test.drv \
- tests/signing-key.pub \
- tests/signing-key.sec \
tests/cve-sample.json \
- tests/civodul.key \
- tests/rsa.key \
- tests/dsa.key \
- tests/ed25519.key \
- tests/ed25519.sec \
- tests/ed25519bis.key \
- tests/ed25519bis.sec \
+ tests/keys/signing-key.pub \
+ tests/keys/signing-key.sec \
+ tests/keys/civodul.pub \
+ tests/keys/rsa.pub \
+ tests/keys/dsa.pub \
+ tests/keys/ed25519.pub \
+ tests/keys/ed25519.sec \
+ tests/keys/ed25519-2.pub \
+ tests/keys/ed25519-2.sec \
+ tests/keys/ed25519-3.pub \
+ tests/keys/ed25519-3.sec \
build-aux/config.rpath \
bootstrap \
doc/build.scm \