summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-05-02 23:16:48 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-05-03 22:41:36 -0400
commit82c0f34c7e62366c415470a3fe1a6a0c46e3d946 (patch)
tree3bd858f113eb839acfab3d1437a1437024905110 /Makefile.am
parent66072a00d78270fb363866438087066e0910add4 (diff)
downloadguix-patches-82c0f34c7e62366c415470a3fe1a6a0c46e3d946.tar
guix-patches-82c0f34c7e62366c415470a3fe1a6a0c46e3d946.tar.gz
maint: Do not xz-compress ISO images.
The xz-compressed image is 23% smaller than the original ISO image (with built-in zlib compression), but the extra decompression step is unconventional and often a hindrance for users. See discussion at <https://lists.gnu.org/archive/html/guix-devel/2021-04/msg00497.html>. * Makefile.am (release): Do not compress ISO images. * doc/guix.texi (USB Stick and DVD Installation): Remove ".xz" suffix from URL and file name. (Copying to a USB Stick, Burning on a DVD): Remove introductory words, @enumerate, and first item. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index de32a0a42b..0a4bb13e5b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -886,9 +886,9 @@ release: dist-with-updated-version all
echo "failed to produced Guix installation image for $$system" >&2 ; \
exit 1 ; \
fi ; \
- xz < "$$image" > "$(releasedir)/$(GUIX_SYSTEM_IMAGE_BASE).$$system.iso.xz.tmp" ; \
- mv "$(releasedir)/$(GUIX_SYSTEM_IMAGE_BASE).$$system.iso.xz.tmp" \
- "$(releasedir)/$(GUIX_SYSTEM_IMAGE_BASE).$$system.iso.xz" ; \
+ cp "$$image" "$(releasedir)/$(GUIX_SYSTEM_IMAGE_BASE).$$system.iso.tmp" ; \
+ mv "$(releasedir)/$(GUIX_SYSTEM_IMAGE_BASE).$$system.iso.tmp" \
+ "$(releasedir)/$(GUIX_SYSTEM_IMAGE_BASE).$$system.iso" ; \
done
# Generate the VM images.
for system in $(GUIX_SYSTEM_VM_SYSTEMS) ; do \