summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-10-15 23:25:08 +0200
committerLudovic Courtès <ludo@gnu.org>2013-10-15 23:25:08 +0200
commit70a9c7202866df594628750f7c4c242f4fd53e60 (patch)
treef711bb41b690d02f98c88006c2405c8fe8bdfd60 /Makefile.am
parentb2ba65c8970a1371244015cc918257f9972454ec (diff)
downloadguix-patches-70a9c7202866df594628750f7c4c242f4fd53e60.tar
guix-patches-70a9c7202866df594628750f7c4c242f4fd53e60.tar.gz
build: Add 'clean-go' target.
* Makefile.am (clean-go): New phony target.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c2d6b9338f..7a74bc8601 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -95,6 +95,10 @@ srfi/srfi-37.scm: srfi/srfi-37.scm.in
endif INSTALL_SRFI_37
+# Handy way to remove the .go files without removing all the rest.
+clean-go:
+ -$(RM) -f $(GOBJECTS)
+
SCM_TESTS = \
tests/base32.scm \
@@ -240,5 +244,5 @@ assert-binaries-available:
$(top_builddir)/pre-inst-env "$(GUILE)" \
"$(top_srcdir)/build-aux/check-available-binaries.scm"
-.PHONY: sync-descriptions gen-ChangeLog
+.PHONY: sync-descriptions gen-ChangeLog clean-go
.PHONY: assert-no-store-file-names assert-binaries-available