summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-10-09 16:13:02 +0200
committerLudovic Courtès <ludo@gnu.org>2013-10-09 16:13:02 +0200
commit668d48a6847bcdc69d2c6e6aa44090f566ecd05b (patch)
tree1424220290e4dc8fc4d9dab889ef8b57bf688992 /Makefile.am
parent129f9e1173494541687be667d41a7223dc3b1b8a (diff)
downloadguix-patches-668d48a6847bcdc69d2c6e6aa44090f566ecd05b.tar
guix-patches-668d48a6847bcdc69d2c6e6aa44090f566ecd05b.tar.gz
build: 'sync-descriptions' now compares GNU package descriptions.
* build-aux/sync-synopses.scm: Rename to... * build-aux/sync-descriptions.scm: ... this. Compare the value of 'gnu-package-doc-description' and 'package-description' and report any mismatch. * Makefile.am (EXTRA_DIST): Adjust accordingly. (sync-synopses): Rename to... (sync-descriptions): ... this.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 22a3b0824d..c2d6b9338f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -156,7 +156,7 @@ EXTRA_DIST = \
build-aux/check-available-binaries.scm \
build-aux/download.scm \
build-aux/list-packages.scm \
- build-aux/sync-synopses.scm \
+ build-aux/sync-descriptions.scm \
srfi/srfi-37.scm.in \
srfi/srfi-64.scm \
srfi/srfi-64.upstream.scm \
@@ -211,12 +211,12 @@ AM_DISTCHECK_CONFIGURE_FLAGS = \
--with-nix-prefix="$(NIX_PREFIX)" \
--enable-daemon
-dist-hook: sync-synopses gen-ChangeLog assert-no-store-file-names
+dist-hook: sync-descriptions gen-ChangeLog assert-no-store-file-names
distcheck-hook: assert-binaries-available
-sync-synopses:
+sync-descriptions:
-$(top_builddir)/pre-inst-env $(GUILE) \
- $(top_srcdir)/build-aux/sync-synopses.scm
+ $(top_srcdir)/build-aux/sync-descriptions.scm
gen-ChangeLog:
if test -d .git; then \
@@ -240,5 +240,5 @@ assert-binaries-available:
$(top_builddir)/pre-inst-env "$(GUILE)" \
"$(top_srcdir)/build-aux/check-available-binaries.scm"
-.PHONY: sync-synopses gen-ChangeLog
+.PHONY: sync-descriptions gen-ChangeLog
.PHONY: assert-no-store-file-names assert-binaries-available