summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-10-27 22:37:49 +0200
committerLudovic Courtès <ludo@gnu.org>2012-10-27 22:37:49 +0200
commit735bb2af10edf4760d23e446b38e76c423bccca7 (patch)
treee075facde1d0da9ef28f1a83d7d87d877197250a /Makefile.am
parenta9f60c421bc6e4ad622d46102617fef9d3a290c6 (diff)
downloadguix-patches-735bb2af10edf4760d23e446b38e76c423bccca7.tar
guix-patches-735bb2af10edf4760d23e446b38e76c423bccca7.tar.gz
build: Fix out-of-source-tree builds.
* Makefile.am (distro/packages/bootstrap/x86_64-linux/guile-bootstrap-2.0.6.tar.xz, distro/packages/bootstrap/i686-linux/guile-bootstrap-2.0.6.tar.xz): Make the target's parent directory. * pre-inst-env.in (DISTRO_BOOTSTRAP_PATH): Add the builddir-relative directory.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d1f3547224..cf3e16bbc6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -98,8 +98,10 @@ DOWNLOAD_FILE = \
"$(top_srcdir)/build-aux/download.scm"
distro/packages/bootstrap/x86_64-linux/guile-bootstrap-2.0.6.tar.xz: guix/utils.go
+ $(MKDIR_P) `dirname "$@"`
$(DOWNLOAD_FILE) "$@" "0467a82cbe4136f60a79eb4176011bf88cf28ea19c9ad9defa365811ff8e11cf"
distro/packages/bootstrap/i686-linux/guile-bootstrap-2.0.6.tar.xz: guix/utils.go
+ $(MKDIR_P) `dirname "$@"`
$(DOWNLOAD_FILE) "$@" "93b537766dfab3ad287143523751e3ec02dd32d3ccaf88ad2d31c63158f342ee"
nobase_nodist_guilemodule_DATA = $(GOBJECTS)