summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-03-10 08:48:19 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-03-10 08:49:48 +0100
commit76bea3f8bcd951ded88dfb7f8cad5bc3e5a1701f (patch)
tree22968402c681697e3fd23e5988d5e79f64a9b1a5 /Makefile.am
parent4399b1cf572b1e23ac80a7b7d63daee34a77e104 (diff)
downloadguix-patches-76bea3f8bcd951ded88dfb7f8cad5bc3e5a1701f.tar
guix-patches-76bea3f8bcd951ded88dfb7f8cad5bc3e5a1701f.tar.gz
ci: Remove hydra support.
This removes hydra support to use Cuirass as the only continuous integration system. * build-aux/hydra/gnu-system.scm: Remove it. * build-aux/hydra/guix-modular.scm: Ditto. * build-aux/hydra/guix.scm: Ditto. * build-aux/cuirass/hydra-to-cuirass.scm: Ditto. * Makefile.am (EXTRA_DIST): Update it. (hydra-jobs.scm): Remove it. (cuirass-jobs.scm): Update it. * build-aux/hydra/evaluate.scm: Move it to ... * build-aux/cuirass/evaluate.scm: ... here. * build-aux/cuirass/guix-modular.scm: Remove it. * build-aux/cuirass/gnu-system.scm: Ditto. * guix/packages.scm (%hydra-supported-systems): Rename it to ... (%cuirass-supported-systems): ... this variable. * build-aux/check-final-inputs-self-contained: Adapt it. * etc/release-manifest.scm: Ditto. * gnu/ci.scm (package->alist): Remove it. (derivation->job): New procedure. (package-job, package-cross-job, cross-jobs, image-jobs, system-test-jobs, tarball-jobs): Use it. (guix-jobs): New procedure. (hydra-jobs): Rename it to ... (cuirass-jobs): ... this procedure.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am29
1 files changed, 6 insertions, 23 deletions
diff --git a/Makefile.am b/Makefile.am
index bb27297096..0f87c958f7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -608,14 +608,7 @@ EXTRA_DIST += \
etc/historical-authorizations \
build-aux/build-self.scm \
build-aux/compile-all.scm \
- build-aux/hydra/evaluate.scm \
- build-aux/hydra/gnu-system.scm \
- build-aux/hydra/guix.scm \
- build-aux/hydra/guix-modular.scm \
- build-aux/cuirass/gnu-system.scm \
- build-aux/cuirass/guix-modular.scm \
build-aux/cuirass/hurd-manifest.scm \
- build-aux/cuirass/hydra-to-cuirass.scm \
build-aux/check-final-inputs-self-contained.scm \
build-aux/check-channel-news.scm \
build-aux/compile-as-derivation.scm \
@@ -955,28 +948,18 @@ check-channel-news: $(GOBJECTS)
$(AM_V_at)$(top_builddir)/pre-inst-env "$(GUILE)" \
"$(top_srcdir)/build-aux/check-channel-news.scm"
-# Compute the Hydra jobs and write them in the target file.
-hydra-jobs.scm: $(GOBJECTS)
- $(AM_V_at)$(MKDIR_P) "`dirname "$@"`"
+# Compute the Cuirass jobs.
+cuirass-jobs: $(GOBJECTS)
+ rm -rf "$@"
+ $(AM_V_at)$(MKDIR_P) "$@"
$(AM_V_GEN)$(top_builddir)/pre-inst-env "$(GUILE)" \
- "$(top_srcdir)/build-aux/hydra/evaluate.scm" \
- "$(top_srcdir)/build-aux/hydra/gnu-system.scm" > "$@.tmp"
- $(AM_V_at)mv "$@.tmp" "$@"
-
-# Compute the Cuirass jobs and write them in the target file.
-cuirass-jobs.scm: $(GOBJECTS)
- $(AM_V_at)$(MKDIR_P) "`dirname "$@"`"
- $(AM_V_GEN)$(top_builddir)/pre-inst-env "$(GUILE)" \
- "$(top_srcdir)/build-aux/hydra/evaluate.scm" \
- "$(top_srcdir)/build-aux/cuirass/gnu-system.scm" \
- cuirass > "$@.tmp"
- $(AM_V_at)mv "$@.tmp" "$@"
+ "$(top_srcdir)/build-aux/cuirass/evaluate.scm" "$@"
.PHONY: gen-ChangeLog gen-AUTHORS gen-tarball-version
.PHONY: assert-no-store-file-names assert-binaries-available
.PHONY: assert-final-inputs-self-contained check-channel-news
.PHONY: clean-go make-go as-derivation authenticate
-.PHONY: update-guix-package update-NEWS release
+.PHONY: update-guix-package update-NEWS cuirass-jobs release
# Downloading up-to-date PO files.