summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-16 23:01:24 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-19 22:20:47 +0100
commit943f33a3263af38c69a2eb60440fe10602104607 (patch)
tree7786acdae26e1d815771f1a4ecce0639c412cda4 /Makefile.am
parent3889a82ef889004bb0835c54e8dc8b23a4a6758f (diff)
downloadguix-patches-943f33a3263af38c69a2eb60440fe10602104607.tar
guix-patches-943f33a3263af38c69a2eb60440fe10602104607.tar.gz
distro: glib: Run the test suite; add DBus.
* distro/packages/glib.scm: Rename to... * gnu/packages/glib.scm: ... this. Update module declaration accordingly. (dbus): New variable. (glib): Change version number to 2.34.3, and adjust URL accordingly. Add a "doc" output. Add #:configure-flags, #:patches, and #:phases arguments. Add DBUS as an input, as well a three patches. * Makefile.am (MODULES): Adjust to file renaming. (dist_patch_DATA): Add `glib-tests-timezone.patch', `glib-tests-homedir.patch', and `glib-tests-desktop.patch'.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 12 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index 9ae0d3002b..fdf4987913 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -131,24 +131,27 @@ GOBJECTS = $(MODULES:%.scm=%.go) guix/config.go
nobase_dist_guilemodule_DATA = $(MODULES)
patchdir = $(guilemoduledir)/gnu/packages/patches
-dist_patch_DATA = \
+dist_patch_DATA = \
gnu/packages/patches/bigloo-gc-shebangs.patch \
- gnu/packages/patches/binutils-ld-new-dtags.patch \
- gnu/packages/patches/cpio-gets-undeclared.patch \
+ gnu/packages/patches/binutils-ld-new-dtags.patch \
+ gnu/packages/patches/cpio-gets-undeclared.patch \
gnu/packages/patches/diffutils-gets-undeclared.patch \
gnu/packages/patches/emacs-configure-sh.patch \
gnu/packages/patches/flex-bison-tests.patch \
gnu/packages/patches/gawk-shell.patch \
- gnu/packages/patches/gettext-gets-undeclared.patch \
- gnu/packages/patches/glibc-bootstrap-system.patch \
- gnu/packages/patches/glibc-no-ld-so-cache.patch \
+ gnu/packages/patches/gettext-gets-undeclared.patch \
+ gnu/packages/patches/glib-tests-desktop.patch \
+ gnu/packages/patches/glib-tests-homedir.patch \
+ gnu/packages/patches/glib-tests-timezone.patch \
+ gnu/packages/patches/glibc-bootstrap-system.patch \
+ gnu/packages/patches/glibc-no-ld-so-cache.patch \
gnu/packages/patches/guile-1.8-cpp-4.5.patch \
gnu/packages/patches/guile-default-utf8.patch \
gnu/packages/patches/guile-relocatable.patch \
gnu/packages/patches/libtool-skip-tests.patch \
gnu/packages/patches/lsh-guile-compat.patch \
gnu/packages/patches/lsh-no-root-login.patch \
- gnu/packages/patches/lsh-pam-service-name.patch \
+ gnu/packages/patches/lsh-pam-service-name.patch \
gnu/packages/patches/m4-gets-undeclared.patch \
gnu/packages/patches/m4-readlink-EINVAL.patch \
gnu/packages/patches/m4-s_isdir.patch \
@@ -156,8 +159,8 @@ dist_patch_DATA = \
gnu/packages/patches/findutils-absolute-paths.patch \
gnu/packages/patches/perl-no-sys-dirs.patch \
gnu/packages/patches/procps-make-3.82.patch \
- gnu/packages/patches/readline-link-ncurses.patch \
- gnu/packages/patches/shishi-gets-undeclared.patch \
+ gnu/packages/patches/readline-link-ncurses.patch \
+ gnu/packages/patches/shishi-gets-undeclared.patch \
gnu/packages/patches/tar-gets-undeclared.patch
bootstrapdir = $(guilemoduledir)/gnu/packages/bootstrap