summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2013-02-14 04:15:25 -0500
committerLudovic Courtès <ludo@gnu.org>2013-02-27 20:55:40 +0100
commit868c923f13e6ed95e1e5ad2bd32d4166842254ea (patch)
treea592f236098878eefea96a8b866ed736fffea11c /Makefile.am
parentd2474c2620a3b4a81e364ee3b741419a778f2472 (diff)
downloadguix-patches-868c923f13e6ed95e1e5ad2bd32d4166842254ea.tar
guix-patches-868c923f13e6ed95e1e5ad2bd32d4166842254ea.tar.gz
Replace individual scripts with master 'guix' script.
* scripts/guix.in: New script. * Makefile.am (bin_SCRIPTS): Add 'scripts/guix'. Remove 'guix-build', 'guix-download', 'guix-import', 'guix-package', and 'guix-gc'. (MODULES): Add 'guix/scripts/build.scm', 'guix/scripts/download.scm', 'guix/scripts/import.scm', 'guix/scripts/package.scm', and 'guix/scripts/gc.scm'. * configure.ac (AC_CONFIG_FILES): Add 'scripts/guix'. Remove 'guix-build', 'guix-download', 'guix-import', 'guix-package', and 'guix-gc'. * guix-build.in, guix-download.in, guix-gc.in, guix-import.in, guix-package.in: Remove shell script boilerplate. Move to guix-COMMAND.in to guix/scripts/COMMAND.scm. Rename module from (guix-COMMAND) to (guix scripts COMMAND). Change "guix-COMMAND" to "guix COMMAND" in usage help string. * pre-inst-env.in: Add "@abs_top_builddir@/scripts" to the front of $PATH. Export $GUIX_UNINSTALLED. * tests/guix-build.sh, tests/guix-daemon.sh, tests/guix-download.sh, tests/guix-gc.sh, tests/guix-package.sh: Use "guix COMMAND" instead of "guix-COMMAND". * doc/guix.texi: Replace all occurrences of "guix-COMMAND" with "guix COMMAND". * po/POTFILES.in: Update.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 7a1b6ad163..5932e1350a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,17 +18,18 @@
# along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
bin_SCRIPTS = \
- guix-build \
- guix-download \
- guix-import \
- guix-package \
- guix-gc
+ scripts/guix
nodist_noinst_SCRIPTS = \
pre-inst-env \
test-env
MODULES = \
+ guix/scripts/build.scm \
+ guix/scripts/download.scm \
+ guix/scripts/import.scm \
+ guix/scripts/package.scm \
+ guix/scripts/gc.scm \
guix/base32.scm \
guix/utils.scm \
guix/derivations.scm \