summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsirgazil via Guix-patches via <guix-patches@gnu.org>2020-02-11 19:14:20 -0500
committerGuix Patches Tester <>2020-02-12 00:17:14 +0000
commitf91ddffe819aa6706edb527f8284efcf4a86e53b (patch)
tree3256bf119f6219d1d21ff31305c01f80912b1ab7
parent48f57932a7e89c3aa13e550221813df1050a17dc (diff)
downloadguix-patches-f91ddffe819aa6706edb527f8284efcf4a86e53b.tar
guix-patches-f91ddffe819aa6706edb527f8284efcf4a86e53b.tar.gz
gnu: Add python-sphinx-autodoc-typehints.
* gnu/packages/sphinx.scm (python-sphinx-autodoc-typehints): New variable.
-rw-r--r--gnu/packages/sphinx.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 4e4abccb04..41bde173c3 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
+;;; Copyright © 2020 sirgazil <sirgazil@zoho.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -597,3 +598,27 @@ to be able to read and render the Doxygen xml output.")
"A utility tool that provides several features that make it easy to
translate and to apply translation to Sphinx generated document.")
(license license:bsd-2)))
+
+(define-public python-sphinx-autodoc-typehints
+ (package
+ (name "python-sphinx-autodoc-typehints")
+ (version "1.10.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sphinx-autodoc-typehints" version))
+ (sha256
+ (base32
+ "1w6zy3cyp24jsdi8dcynrinafw2a0k5vblqy9lncm6j7cw0iicx6"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)))
+ (propagated-inputs
+ `(("python-sphinx" ,python-sphinx)))
+ (home-page "https://github.com/agronholm/sphinx-autodoc-typehints")
+ (synopsis "Type hints support for the Sphinx autodoc extension")
+ (description
+ "This extension allows you to use Python 3 annotations for
+documenting acceptable argument types and return value types of
+functions.")
+ (license license:expat)))