summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElais Player <elais@samus.hsd1.nm.comcast.net>2020-04-28 13:44:00 -0600
committerGuix Patches Tester <>2020-04-29 01:50:17 +0100
commite67ba28b4548d3817daa644d9d60ed1b06ca8da3 (patch)
treefcc488111be1715466f701b85486dccc9cfbec73
parentf93eebbf9ca8477404827f44daf3121b11120e99 (diff)
downloadguix-patches-e67ba28b4548d3817daa644d9d60ed1b06ca8da3.tar
guix-patches-e67ba28b4548d3817daa644d9d60ed1b06ca8da3.tar.gz
Add emacs-boon package
This patch adds boon modal editing packages.
-rw-r--r--gnu/packages/emacs-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2c61c4189d..13d539e607 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -68,6 +68,7 @@
;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
;;; Copyright © 2020 Jérémy Korwin-Zmijowski <jeremy@korwin-zmijowski.fr>
;;; Copyright © 2020 Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
+;;; Copyright © 2020 Elais Player <elais@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22662,3 +22663,34 @@ deleting them with @code{(setq delete-by-moving-to-trash t)}. This package
provides a simple but convenient user interface to manage those trashed
files.")
(license license:gpl3+)))
+
+(define-public emacs-boon
+ (package
+ (name "emacs-boon")
+ (version "1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jyp/boon/")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ss9bjs34q41pa0g0nbdzd8fwpjcbd2239rdlx5aykfv9v0b8j77"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-expand-region" ,emacs-expand-region)
+ ("spaceline" ,emacs-spaceline)
+ ("powerline" ,emacs-powerline)
+ ("emacs-dash" ,emacs-dash)
+ ("emacs-multiple-cursors" ,emacs-multiple-cursors)))
+ (home-page "https://github.com/jyp/boon")
+ (synopsis "Ergonomic Command Mode for Emacs.")
+ (description
+ "Boon brings modal editing capabilities to Emacs and...
+
+- It tries to be as ergonomic as possible.
+- It remains lightweight (~300 loc for its core.)
+- It attempts to integrate with Emacs as smoothly as possible")
+ (license license:gpl3)))