summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEkaitz Zarraga <ekaitz@elenq.tech>2020-04-07 18:56:06 +0200
committerGuix Patches Tester <>2020-04-25 20:49:12 +0100
commitdb546e89a4a4c018fb756c2f246cc22b8b16596d (patch)
tree2415b1a8a347b1a7f3e90c06a7e03fb01d8437ca
parent8cf6d150b4492145369cb8d39f54ad98d3b27301 (diff)
downloadguix-patches-db546e89a4a4c018fb756c2f246cc22b8b16596d.tar
guix-patches-db546e89a4a4c018fb756c2f246cc22b8b16596d.tar.gz
gnu: Add meshlab.
* gnu/packages/engineering.scm (meshlab): New variable.
-rw-r--r--gnu/packages/engineering.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index ac50efb923..2fc2ecdd88 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2511,3 +2511,52 @@ without any changes. And programmers that are familiar with the magellan API
can continue using it with a free library without the restrictions of the
official SDK.")
(license license:bsd-3)))
+
+(define-public meshlab
+ (let ((version "2020.04"))
+ (package
+ (name "meshlab")
+ (version version)
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cnr-isti-vclab/meshlab")
+ (commit (string-append "Meshlab-" version))
+ (recursive? #t)))
+ (sha256
+ (base32 "1vx9jcsnnxvzi90pcxpp7p72cqg3cm6jiivdmrxkzhr2fiz3pfvr"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("qtbase" ,qtbase)
+ ("qtscript" ,qtscript)
+ ("qtxmlpatterns" ,qtxmlpatterns)
+ ("mesa", mesa)
+ ("glu", glu)))
+ (arguments
+ `(#:tests? #f ; Has no tests
+ #:phases
+ (modify-phases
+ %standard-phases
+ (add-after
+ 'unpack 'go-to-source-dir
+ (lambda _ (chdir "src") #t))
+ (add-after
+ 'install 'move-files
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((lib (string-append (assoc-ref outputs "out")
+ "/lib")))
+ (rename-file
+ (string-append lib "/meshlab/libmeshlab-common.so")
+ (string-append lib "/libmeshlab-common.so"))
+ #t))))))
+ (synopsis "3D triangular mesh processing and editing software")
+ (home-page "http://www.meshlab.net/")
+ (description "MeshLab is a system for the processing and
+editing of unstructured large 3D triangular meshes. It is aimed to help the
+processing of the typical not-so-small unstructured models arising in 3D
+scanning, providing a set of tools for editing, cleaning, healing, inspecting,
+rendering and converting this kind of meshes. These tools include MeshLab
+proper, a versatile program with a graphical user interface, and meshlabserver,
+a program that can perform mesh processing tasks in batch mode, without a
+GUI.")
+ (license license:gpl3+))))