summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2020-03-18 20:59:09 -0500
committerGuix Patches Tester <>2020-03-19 05:48:15 +0000
commitc6c754b4ea7c454fc05fb8b276dea0152ecc5fdb (patch)
tree610064257936a59df92b680358dff63837807753
parente72b01bbd1ea686653bfc2de1379f878c86b7d36 (diff)
downloadguix-patches-c6c754b4ea7c454fc05fb8b276dea0152ecc5fdb.tar
guix-patches-c6c754b4ea7c454fc05fb8b276dea0152ecc5fdb.tar.gz
gnu: Add emacs-major-mode-hydra.
* gnu/packages/emacs-xyz.scm (emacs-major-mode-hydra): New variable. gnu: Add emacs-major-mode-hydra. * gnu/packages/emacs-xyz.scm (emacs-major-mode-hydra): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 477ecbdc87..976bf2821a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5611,6 +5611,26 @@ mode-specific key bindings. It is intended for use as a library only; see
package @code{emacs-major-mode-hydra} for a user-friendly interface.")
(license license:gpl3+)))
+(define-public emacs-major-mode-hydra
+ (package
+ (inherit emacs-pretty-hydra)
+ (name "emacs-major-mode-hydra")
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-pretty-hydra" ,emacs-pretty-hydra)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'add-source-to-load-path 'remove-pretty-hydra
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; pretty-hydra is provided by dependency.
+ (delete-file "pretty-hydra.el")
+ #t)))))
+ (synopsis "Create nice-looking hydras")
+ (description
+ "This package provides the macro @code{pretty-hydra-define} to define
+hydras with one column per group of heads.")))
+
(define-public emacs-ivy
(package
(name "emacs-ivy")