summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-04-20 12:16:53 +0300
committerGuix Patches Tester <>2020-04-20 10:19:11 +0100
commitbef9e7706bf85d09e27c8e4cf660af5746351131 (patch)
tree05f21e876be06b43501aed74bbdaa123896aadc1
parent10af34cd7f1f4f9fb50db826d06233c83a9c0439 (diff)
downloadguix-patches-bef9e7706bf85d09e27c8e4cf660af5746351131.tar
guix-patches-bef9e7706bf85d09e27c8e4cf660af5746351131.tar.gz
Add fdroidcl.
I made a couple of changes to the patch. It now downloads the source using git-fetch and I updated the inputs a bit. For the tests, I'm afraid you're going to need to package the missing package.
-rw-r--r--gnu/packages/android.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 17f5f41fcb..a32d6c570c 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2019 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020 Sergey Trofimov <sarg@sarg.org.ru>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32,6 +33,7 @@
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system android-ndk)
+ #:use-module (guix build-system go)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
#:use-module ((guix licenses) #:prefix license:)
@@ -41,6 +43,7 @@
#:use-module (gnu packages docker)
#:use-module (gnu packages gcc)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages golang)
#:use-module (gnu packages java)
#:use-module (gnu packages linux)
#:use-module (gnu packages pcre)
@@ -946,6 +949,39 @@ publishing, or to assist in creating, testing and submitting metadata to the
main repository.")
(license license:agpl3+)))
+(define-public fdroidcl
+ (package
+ (name "fdroidcl")
+ (version "0.5.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mvdan/fdroidcl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rxcdyy2j34z0ql9d62w7ivsch9xihjnpb1z9kgy9q46vl8zhhy0"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "mvdan.cc/fdroidcl"
+ #:tests? #f ; TODO.
+ #:install-source? #f))
+ (inputs
+ `(("go-github-com-kr-pretty"
+ ,go-github-com-kr-pretty)))
+ (native-inputs
+ `(;; used in tests
+ ;; ("go-github-com-rogpeppe-go-internal-testscript"
+ ;; ,go-github-com-rogpeppe-go-internal-testscript)
+ ))
+ (synopsis "F-Droid desktop client")
+ (description
+ "While the Android client integrates with the system with regular update
+checks and notifications, this is a simple command line client that talks to
+connected devices via ADB.")
+ (home-page "https://github.com/mvdan/fdroidcl")
+ (license license:bsd-3)))
+
(define-public enjarify
(package
(name "enjarify")