summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Newsome <jnewsome@torproject.org>2022-08-03 20:47:19 -0500
committerGuix Patches Tester <>2022-08-04 02:52:10 +0100
commitb87eec51c0e3fad2e372801938d7e5c7b521f3f7 (patch)
treef4c51350863cc864050c307cf22130be585a23e7
parent21da362903946a831843fddc2265f824b343876f (diff)
downloadguix-patches-b87eec51c0e3fad2e372801938d7e5c7b521f3f7.tar
guix-patches-b87eec51c0e3fad2e372801938d7e5c7b521f3f7.tar.gz
gnu: rust: Use rust-1.60.0issue-54439
* gnu/packages/rust.scm (rust-1.58, rust-1.59, rust-1.60, rust): Add rust-1.58, rust-1.59, and rust-1.60, and update rust to be based on rust-1.60 instead of rust-1.57.
-rw-r--r--gnu/packages/rust.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index e9d9ddcb9e..4ee25d86b3 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -645,8 +645,35 @@ safety and thread safety guarantees.")
(define rust-1.57
(rust-bootstrapped-package
+ ;; Verified that it *doesn't* build with 1.55. e.g.:
+ ;; * feature `edition2021` is required
rust-1.56 "1.57.0" "06jw8ka2p3kls8p0gd4p0chhhb1ia1mlvj96zn78n7qvp71zjiim"))
+(define rust-1.58
+ (rust-bootstrapped-package
+ ;; Verified that it *doesn't* build with 1.56. e.g.:
+ ;; * error: attributes starting with `rustc` are reserved for use by the
+ ;; `rustc` compiler
+ ;; * error: cannot find attribute `rustc_do_not_const_check` in this scope
+ ;; * error[E0522]: definition of an unknown language item:
+ ;; `const_eval_select_ct`
+ rust-1.57 "1.58.1" "1iq7kj16qfpkx8gvw50d8rf7glbm6s0pj2y1qkrz7mi56vfsyfd8"))
+
+(define rust-1.59
+ (rust-bootstrapped-package
+ ;; Verified that it *doesn't* build with 1.57. e.g.:
+ ;; * error: `doc(primitive)` should never have been stable
+ ;; * error[E0522]: definition of an unknown language item:
+ ;; `generator_return`
+ ;; * error[E0206]: the trait `Copy` may not be implemented for this type
+ rust-1.58 "1.59.0" "1yc5bwcbmbwyvpfq7zvra78l0r8y3lbv60kbr62fzz2vx2pfxj57"))
+
+(define rust-1.60
+ (rust-bootstrapped-package
+ ;; Verified that it *doesn't* build with 1.58. e.g.:
+ ;; * error: unknown codegen option: `symbol-mangling-version`
+ rust-1.59 "1.60.0" "1drqr0a26x1rb2w3kj0i6abhgbs3jx5qqkrcwbwdlx7n3inq5ji0"))
+
;;; Note: Only the latest versions of Rust are supported and tested. The
;;; intermediate rusts are built for bootstrapping purposes and should not
;;; be relied upon. This is to ease maintenance and reduce the time
@@ -655,7 +682,7 @@ safety and thread safety guarantees.")
;;; Here we take the latest included Rust, make it public, and re-enable tests
;;; and extra components such as rustfmt.
(define-public rust
- (let ((base-rust rust-1.57))
+ (let ((base-rust rust-1.60))
(package
(inherit base-rust)
(outputs (cons "rustfmt" (package-outputs base-rust)))