summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandru-Sergiu Marton <brown121407@gmail.com>2020-01-04 10:52:06 +0200
committerGuix Patches Tester <>2020-01-12 09:38:02 +0000
commita8cd5f046baa8edd762de97d0f4e168dbe5cb830 (patch)
tree513fdbf755ec9a6cea1ad86c14a9b5e484a67780
parentd75a0cd98649c610c8c6ed05011233a49af156e9 (diff)
downloadguix-patches-a8cd5f046baa8edd762de97d0f4e168dbe5cb830.tar
guix-patches-a8cd5f046baa8edd762de97d0f4e168dbe5cb830.tar.gz
gnu: Add ghc-http-reverse-proxy.
* gnu/packages/haskell-web.scm (ghc-http-reverse-proxy): New variable.
-rw-r--r--gnu/packages/haskell-web.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 5888e8542e..bf96ca88ca 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Robert Vollmert <rob@vllmrt.net>
;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
+;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -377,6 +378,48 @@ contents of the HTTP connection. It also provides higher-level functions
which allow you to avoid direct usage of conduits.")
(license license:bsd-3)))
+(define-public ghc-http-reverse-proxy
+ (package
+ (name "ghc-http-reverse-proxy")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/http-reverse-proxy/"
+ "http-reverse-proxy-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1a6i5njf85b2lhg8m83njagcf09wih5q2irnyb2890s724qr277v"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-case-insensitive" ,ghc-case-insensitive)
+ ("ghc-http-types" ,ghc-http-types)
+ ("ghc-word8" ,ghc-word8)
+ ("ghc-blaze-builder" ,ghc-blaze-builder)
+ ("ghc-http-client" ,ghc-http-client)
+ ("ghc-wai" ,ghc-wai)
+ ("ghc-network" ,ghc-network)
+ ("ghc-conduit" ,ghc-conduit)
+ ("ghc-conduit-extra" ,ghc-conduit-extra)
+ ("ghc-wai-logger" ,ghc-wai-logger)
+ ("ghc-resourcet" ,ghc-resourcet)
+ ("ghc-unliftio" ,ghc-unliftio)
+ ("ghc-streaming-commons" ,ghc-streaming-commons)))
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)
+ ("ghc-warp" ,ghc-warp)
+ ("ghc-http-conduit" ,ghc-http-conduit)))
+ (home-page
+ "https://github.com/fpco/http-reverse-proxy")
+ (synopsis
+ "Reverse proxy HTTP requests, either over raw sockets or with WAI")
+ (description
+ "Provides a simple means of reverse-proxying HTTP requests. The raw
+approach uses the same technique as leveraged by keter, whereas the WAI
+approach performs full request/response parsing via WAI and http-conduit.")
+ (license license:bsd-3)))
+
(define-public ghc-wai
(package
(name "ghc-wai")