summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2020-03-18 20:59:49 -0500
committerGuix Patches Tester <>2020-03-21 23:14:13 +0000
commita08f49d487279490fc1b5bd1041c7c2b47197c82 (patch)
tree4c757856735db3dbd2d1f1f3d1d08ecb089a1f62
parent6f3475655a60e25328d6fc8a1ce4af19620f0a02 (diff)
downloadguix-patches-a08f49d487279490fc1b5bd1041c7c2b47197c82.tar
guix-patches-a08f49d487279490fc1b5bd1041c7c2b47197c82.tar.gz
gnu: Add emacs-pretty-hydra.
* gnu/packages/emacs-xyz.scm (emacs-pretty-hydra): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1ea3155807..50eec6d516 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5486,6 +5486,34 @@ the Hydra very seamless; it's like a minor mode that disables itself
automatically.")
(license license:gpl3+)))
+(define-public emacs-pretty-hydra
+ (package
+ (name "emacs-pretty-hydra")
+ (version "0.2.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jerrypnz/major-mode-hydra.el.git")
+ (commit version)))
+ (sha256
+ (base32
+ "08a15knkdq35pzjq82imff016fbfdib5q4glg2xmdy2b5fnk7jqa"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-hydra" ,emacs-hydra)
+ ("emacs-s" ,emacs-s)))
+ (arguments
+ `(#:exclude (cons "^major-mode-hydra\\.el" %default-exclude)))
+ (home-page "https://github.com/jerrypnz/major-mode-hydra.el")
+ (synopsis "Major mode keybindings managed by Hydra")
+ (description
+ "This package offers an hydra-based method of managing major
+mode-specific key bindings. It is intended for use as a library only; see
+package @code{emacs-major-mode-hydra} for a user-friendly interface.")
+ (license license:gpl3+)))
+
(define-public emacs-ivy
(package
(name "emacs-ivy")