summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-04-16 09:34:09 +0100
committerGuix Patches Tester <>2020-04-16 09:36:05 +0100
commit83f907c31f014686a0b59d57ec2051a40530044a (patch)
treed2575679bb44e350a8a3e6f07b7e6ee908c95af8
parent3f782a6d957ab3aa5fbb427d85bd37b5445d6fee (diff)
downloadguix-patches-83f907c31f014686a0b59d57ec2051a40530044a.tar
guix-patches-83f907c31f014686a0b59d57ec2051a40530044a.tar.gz
gnu: gnutls: Enable p11-kit.
Everywhere except mips64el, where a comment says it doesn't work. I can't test as I can't build this on mips64el anyway. This change will enable running the tests for libcacard. * gnu/packages/tls.scm (gnutls)[arguments]: Only specify --without-p11-kit on mips64el. [inputs]: Include the p11-kit for all systems except mips64el.
-rw-r--r--gnu/packages/tls.scm20
1 files changed, 15 insertions, 5 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 3eb32fc27a..85f159a401 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -181,7 +181,7 @@ living in the same process.")
`(; Ensure we don't keep a reference to this buggy software.
#:disallowed-references (,net-tools)
#:configure-flags
- (list
+ (cons*
;; GnuTLS doesn't consult any environment variables to specify
;; the location of the system-wide trust store. Instead it has a
;; configure-time option. Unless specified, its configure script
@@ -202,9 +202,14 @@ living in the same process.")
(string-append "--with-guile-extension-dir="
"$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/extensions")
- ;; FIXME: Temporarily disable p11-kit support since it is not
- ;; working on mips64el.
- "--without-p11-kit")
+ (let ((system ,(or (%current-target-system)
+ (%current-system))))
+ (if (string-prefix? "mips64el" system)
+ (list
+ ;; FIXME: Temporarily disable p11-kit support since it is
+ ;; not working on mips64el.
+ "--without-p11-kit")
+ '())))
#:phases (modify-phases %standard-phases
(add-after
@@ -227,7 +232,12 @@ living in the same process.")
("pkg-config" ,pkg-config)
("which" ,which)))
(inputs
- `(("guile" ,guile-2.2)))
+ `(("guile" ,guile-2.2)
+ ,@(let ((system (or (%current-target-system)
+ (%current-system))))
+ (if (string-prefix? "mips64el" system)
+ '()
+ `(("p11-kit" ,p11-kit))))))
(propagated-inputs
;; These are all in the 'Requires.private' field of gnutls.pc.
`(("libtasn1" ,libtasn1)