summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-03-29 22:32:24 +0200
committerGuix Patches Tester <>2020-03-29 21:34:11 +0100
commit744b99b11af14b6c4955f912a0a9c6a81f814ae6 (patch)
tree7af7700b3859516f2463e53bb5404396d679d1f2
parente5b44b06b3fb19c897fb3e430bd41941905e101f (diff)
downloadguix-patches-744b99b11af14b6c4955f912a0a9c6a81f814ae6.tar
guix-patches-744b99b11af14b6c4955f912a0a9c6a81f814ae6.tar.gz
gnu: flint: Build with ntl.
* gnu/packages/algebra.scm (flint)[inputs]: Add ntl. [arguments]: Pass --with-ntl to configure.
-rw-r--r--gnu/packages/algebra.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 081666c38f..67a119329c 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -446,6 +446,8 @@ or text interfaces) or as a C++ library.")
"11syazv1a8rrnac3wj3hnyhhflpqcmq02q8pqk2m6g2k6h0gxwfb"))
(patches (search-patches "flint-ldconfig.patch"))))
(build-system gnu-build-system)
+ (inputs
+ `(("ntl" ,ntl)))
(propagated-inputs
`(("gmp" ,gmp)
("mpfr" ,mpfr))) ; header files from both are included by flint/arith.h
@@ -457,13 +459,15 @@ or text interfaces) or as a C++ library.")
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
(gmp (assoc-ref inputs "gmp"))
- (mpfr (assoc-ref inputs "mpfr")))
+ (mpfr (assoc-ref inputs "mpfr"))
+ (ntl (assoc-ref inputs "ntl")))
;; do not pass "--enable-fast-install", which makes the
;; homebrew configure process fail
(invoke "./configure"
(string-append "--prefix=" out)
(string-append "--with-gmp=" gmp)
- (string-append "--with-mpfr=" mpfr))
+ (string-append "--with-mpfr=" mpfr)
+ (string-append "--with-ntl=" ntl))
#t))))))
(synopsis "Fast library for number theory")
(description