summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-01-26 11:12:14 -0800
committerGuix Patches Tester <>2020-01-27 14:59:08 +0000
commit6702804a061210ba736a12c431ba231c0a84974e (patch)
tree3b7b26db98200b9474c3b1f0c0da4c608650c32d
parent5e61de242156cdb3314abac168d9682ca7a4c28f (diff)
downloadguix-patches-6702804a061210ba736a12c431ba231c0a84974e.tar
guix-patches-6702804a061210ba736a12c431ba231c0a84974e.tar.gz
gnu: Add ghc-filelock.
* gnu/packages/haskell-xyz.scm (ghc-filelock): New variable.
-rw-r--r--gnu/packages/haskell-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index af940f02fc..73a9eae69b 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -3979,6 +3979,31 @@ the files in a directory, and turn them into @code{(path, bytestring)} pairs
embedded in your Haskell code.")
(license license:bsd-3)))
+(define-public ghc-filelock
+ (package
+ (name "ghc-filelock")
+ (version "0.1.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/filelock/filelock-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "04qimhz78jjndk686dblkx06l9jscq2q9gyr014a4pbfj4iljgi5"))))
+ (build-system haskell-build-system)
+ (native-inputs `(("ghc-async" ,ghc-async)))
+ (home-page
+ "http://github.com/takano-akio/filelock")
+ (synopsis
+ "Portable interface to file locking (flock / LockFileEx)")
+ (description
+ "This package provides an interface to Windows and Unix file locking
+functionalities.")
+ (license license:public-domain)))
+
(define-public ghc-filemanip
(package
(name "ghc-filemanip")