summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2020-02-03 11:55:06 +0100
committerGuix Patches Tester <>2020-02-03 10:57:09 +0000
commit5998a91ff85e2e2b69797f254321ba3eec9779c3 (patch)
tree285321ed0fde4ebbe6770bb82d6a291ff8249cb1
parentd441a6455051d70d7ff0d951c7e68318499b1739 (diff)
downloadguix-patches-5998a91ff85e2e2b69797f254321ba3eec9779c3.tar
guix-patches-5998a91ff85e2e2b69797f254321ba3eec9779c3.tar.gz
gnu: Add chatty.
* gnu/packages/messaging.scm (chatty): New variable.
-rw-r--r--gnu/packages/messaging.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index b1276e267b..6db2d570d1 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2019, 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2019, 2020 Timotej Lazar <timotej.lazar@araneo.si>
+;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -55,6 +56,7 @@
#:use-module (gnu packages documentation)
#:use-module (gnu packages enchant)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
@@ -1995,4 +1997,39 @@ support for high performance Telegram Bot creation.")
(home-page "https://core.telegram.org/tdlib")
(license license:boost1.0))))
+(define-public chatty
+ (package
+ (name "chatty")
+ (version "0.1.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://source.puri.sm/Librem5/chatty.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1prqd2dnib3j12pjiplzr2rim9q617vmvzv76lgmz0n3bmp7v7ma"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils) ;for update-desktop-database
+ ("evolution-data-server" ,evolution-data-server) ;libebook-contacts
+ ("folks" ,folks)
+ ("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gtk+:bin" ,gtk+ "bin")
+ ("libgcrypt" ,libgcrypt)
+ ("libgee" ,libgee)
+ ("libhandy" ,libhandy)
+ ("pidgin" ,pidgin)
+ ("pkg-config" ,pkg-config)
+ ("sqlite" ,sqlite)))
+ (propagated-inputs
+ `(("hicolor-icon-theme" ,hicolor-icon-theme)))
+ (synopsis "Mobile client for XMPP and SMS messaging")
+ (description "Chatty is a chat program for XMPP and SMS. It works on mobile
+as well as on desktop platforms. It's based on libpurple and ModemManager.")
+ (home-page "https://source.puri.sm/Librem5/chatty")
+ (license license:gpl3+)))
+
;;; messaging.scm ends here