summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-03-28 17:11:51 -0700
committerGuix Patches Tester <>2020-03-30 03:37:11 +0100
commit5672212cca222f3c78ff28938cb635586d7d603f (patch)
tree10a50e6329ff2ae01d0470d48fa2f0c90c20754e
parent3e3364fc526e1a54ea7744361ffcf6a59a6610a8 (diff)
downloadguix-patches-5672212cca222f3c78ff28938cb635586d7d603f.tar
guix-patches-5672212cca222f3c78ff28938cb635586d7d603f.tar.gz
gnu: Add emacs-next-no-x.
Hi Guix, I wanted to give emacs 27 a try without x. So far so good! Thanks! John >From a1877e1d8d0317de69e1ee915d9624747a66e6bf Mon Sep 17 00:00:00 2001 From: John Soo <jsoo1@asu.edu> Date: Thu, 19 Mar 2020 10:39:15 -0700 Subject: [PATCH] gnu: Add emacs-next-no-x. * gnu/packages/emacs.scm (emacs-next-no-x): New variable.
-rw-r--r--gnu/packages/emacs.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 3d0368be4e..3de8b64506 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2019 Valentin Ignatev <valentignatev@gmail.com>
;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2019 Amin Bandali <bandali@gnu.org>
+;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -388,6 +389,33 @@ editor (console only)")
;; These depend on libx11, so remove them as well.
"libotf" "m17n-lib" "dbus")))))
+(define-public emacs-next-no-x
+ (package
+ (inherit emacs-next)
+ (name "emacs-next-no-x")
+ (synopsis (package-synopsis emacs-no-x))
+ (build-system gnu-build-system)
+ (arguments
+ (substitute-keyword-arguments (package-arguments emacs-next)
+ ((#:modules _)
+ `((guix build emacs-utils)
+ ,@%gnu-build-system-modules))
+ ((#:imported-modules _)
+ `((guix build emacs-utils)
+ ,@%gnu-build-system-modules))
+ ((#:phases p)
+ `(modify-phases ,p
+ (delete 'restore-emacs-pdmp)))))
+ (inputs
+ (fold alist-delete
+ (package-inputs emacs-next)
+ '("libx11" "gtk+" "libxft" "libtiff" "giflib" "libjpeg"
+ "imagemagick" "libpng" "librsvg" "libxpm" "libice"
+ "libsm"
+
+ ;; These depend on libx11, so remove them as well.
+ "libotf" "m17n-lib" "dbus")))))
+
(define-public emacs-no-x-toolkit
(package (inherit emacs)
(name "emacs-no-x-toolkit")