summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2020-03-16 16:32:25 +0100
committerGuix Patches Tester <>2020-03-16 18:30:19 +0000
commit4d2ddcd82923a62be565cc6c356c690f793ec664 (patch)
tree24dd6ad4be7972cee47eb7cfdd86de21961fff73
parent057b34478fd8ec7fa1de8c66b125b197d02b3ee5 (diff)
downloadguix-patches-4d2ddcd82923a62be565cc6c356c690f793ec664.tar
guix-patches-4d2ddcd82923a62be565cc6c356c690f793ec664.tar.gz
gnu: ocaml-menhir: Update to 20200211.
* gnu/packages/ocaml.scm (ocaml-menhir): Update to 20200211. [build-system]: Switch from gnu to dune. [arguments]: Remove phases and make-flags. [native-inputs]: remove field.
-rw-r--r--gnu/packages/ocaml.scm15
1 files changed, 4 insertions, 11 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 35701039ad..ba1214ee9b 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -706,7 +706,7 @@ Emacs.")
(define-public ocaml-menhir
(package
(name "ocaml-menhir")
- (version "20181113")
+ (version "20200211")
(source
(origin
(method git-fetch)
@@ -715,19 +715,12 @@ Emacs.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1iqdf64ayq4s3d9jkwhs3s8wqc2s48b292hp0kcjsskfhcvwg0kr"))))
- (build-system ocaml-build-system)
+ (base32 "019izf51kdc7pzkw68zg8a2alc8lxw1gwdp7in970mr90n16b5zj"))))
+ (build-system dune-build-system)
(inputs
`(("ocaml" ,ocaml)))
- (native-inputs
- `(("ocamlbuild" ,ocamlbuild)))
(arguments
- `(#:make-flags `("USE_OCAMLFIND=true"
- ,(string-append "PREFIX=" (assoc-ref %outputs "out")))
- #:tests? #f ; No check target
- #:phases
- (modify-phases %standard-phases
- (delete 'configure))))
+ `(#:tests? #f)) ; No check target
(home-page "http://gallium.inria.fr/~fpottier/menhir/")
(synopsis "Parser generator")
(description "Menhir is a parser generator. It turns high-level grammar