summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdouard Klein <edk@beaver-labs.com>2020-05-26 13:40:20 +0200
committerGuix Patches Tester <>2020-05-26 12:42:09 +0100
commit443a328da40bd693c69b77611d08ebed318b77f1 (patch)
treef43caed973cc86616708e4c89a9cf7ad7fec18e7
parent20f524a44b1a9728045be1198ff795697557796c (diff)
downloadguix-patches-443a328da40bd693c69b77611d08ebed318b77f1.tar
guix-patches-443a328da40bd693c69b77611d08ebed318b77f1.tar.gz
gnu: Move nose from propagated to native in python-iml
* gnu/packages/machine-learning.scm (python-iml): Make python-nose a native input instead of a propagated input.
-rw-r--r--gnu/packages/machine-learning.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 1b678d3d20..17d01bc656 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Konrad Hinsen <konrad.hinsen@fastmail.net>
+;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1817,10 +1818,11 @@ advanced research.")
(build-system python-build-system)
(propagated-inputs
`(("ipython" ,python-ipython)
- ("nose" ,python-nose)
("numpy" ,python-numpy)
("pandas" ,python-pandas)
("scipy" ,python-scipy)))
+ (native-inputs
+ `(("nose" ,python-nose)))
(home-page "https://github.com/interpretable-ml/iml")
(synopsis "Interpretable Machine Learning (iML) package")
(description "Interpretable ML (iML) is a set of data type objects,