summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>2020-04-15 00:04:47 -0500
committerGuix Patches Tester <>2020-04-15 06:07:08 +0100
commit4242eb8b21086e92da4ede460a31253584782ebd (patch)
treee6fbace17ed0b53fb1c42520e2934394860dd533
parent06e48de57ea0422a0b054d6ef7fb61add7c4ae99 (diff)
downloadguix-patches-4242eb8b21086e92da4ede460a31253584782ebd.tar
guix-patches-4242eb8b21086e92da4ede460a31253584782ebd.tar.gz
gnu: Add emacs-moody.
* gnu/packages/emacs-xyz.scm (emacs-moody): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a9550ee112..364cec47da 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -507,6 +507,33 @@ Alternatively the menu can be bound globally, for example:
@code{(global-set-key [S-down-mouse-3] 'minions-minor-modes-menu)}.")
(license license:gpl3+)))
+(define-public emacs-moody
+ (let ((commit "2751d36152abcc2ac1479225392182b53f1e02dd")
+ (revision "1"))
+ (package
+ (name "emacs-moody")
+ ;; version 4.0 is a bit old (2018)
+ (version (git-version "0.5.3" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tarsius/moody.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xyw4l42053595r76lj8safsx6pj25as0107wd96by3h7dg9m586"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/tarsius/moody")
+ (synopsis "Tabs and ribbons for Emacs mode-line")
+ (description
+ "@code{emacs-moody} provides utilities for displaying elements of
+the mode line as tabs and ribbons. It also provides replacements for a few
+built-in elements. The biggest differences to similar packages is that
+this one is much simpler and much more consistent. When using this package,
+then only the color of the mode line changes when a window becomes in-/active.")
+ (license license:gpl3+))))
+
(define-public emacs-treepy
(package
(name "emacs-treepy")