summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-07-30 15:15:02 +0200
committerGuix Patches Tester <>2020-07-30 14:18:07 +0100
commit2f327ef014bc1454bef882c5fbcc3bc7e6cd7511 (patch)
tree987ab9fe2ca43b4b6d52776c1288877c12641671
parent39386de24439c81f1a7c683ae8c5dd1c5f24e09e (diff)
downloadguix-patches-2f327ef014bc1454bef882c5fbcc3bc7e6cd7511.tar
guix-patches-2f327ef014bc1454bef882c5fbcc3bc7e6cd7511.tar.gz
gnu: poetry: Fix a problem with a dependency.
* gnu/packages/python-xyz.scm (poetry) [arguments]: Modify the required version of python-tomlkit.
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a5c2e60ce4..550886082c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12382,7 +12382,11 @@ database, file, dict stores. Cachy supports python versions 2.7+ and 3.2+.")
(substitute* "setup.py"
;; poetry won't update version as 21.0.0 relies on python > 3.6
(("keyring>=20.0.1,<21.0.0") "keyring>=21.0.0,<22.0.0")
- (("pyrsistent>=0.14.2,<0.15.0") "pyrsistent>=0.14.2,<0.17.0"))
+ (("pyrsistent>=0.14.2,<0.15.0") "pyrsistent>=0.14.2,<0.17.0")
+ ;; Reported upstream:
+ ;; <https://github.com/python-poetry/poetry/issues/2752>.
+ (("tomlkit>=0.5.11,<0.6.0") "tomlkit>=0.5.11,<0.7.0")
+ )
#t)))))
(propagated-inputs
`(("python-cachecontrol" ,python-cachecontrol)