summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>2020-03-11 21:50:14 -0600
committerGuix Patches Tester <>2020-03-13 03:18:17 +0000
commit2c83e984848c5501bbabc5619fa66f052d1987c4 (patch)
treec7da9b42a93dea367eb7448a41ecd88b83131a71
parent63299f2840edcd5d942b3433ffb205fcc1fb6eb4 (diff)
downloadguix-patches-2c83e984848c5501bbabc5619fa66f052d1987c4.tar
guix-patches-2c83e984848c5501bbabc5619fa66f052d1987c4.tar.gz
gnu: Add widelands.
* gnu/packages/games.scm (widelands): New variable.
-rw-r--r--gnu/packages/games.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 9b4ff4df9a..950c9dbf2e 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -46,6 +46,7 @@
;;; Copyright © 2019, 2020 Timotej Lazar <timotej.lazar@araneo.si>
;;; Copyright © 2019 Josh Holland <josh@inv.alid.pw>
;;; Copyright © 2017, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2020 Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -10157,3 +10158,55 @@ best human chess grandmasters. It can be used with UCI-compatible GUIs like
ChessX.")
(home-page "https://stockfishchess.org/")
(license license:gpl3+)))
+
+(define-public widelands
+ (package
+ (name "widelands")
+ (version "20")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://launchpad.net/widelands/build20/build20/+download/"
+ name "-build" version ".tar.bz2"))
+ (sha256
+ (base32 "1cmwfwk7j6yi2pwmm4rm57s23sdzasqf53nx6567sdagqyc4sn9q"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags
+ (let* ((out (assoc-ref %outputs "out"))
+ (share (string-append out "/share")))
+ (list "-DCMAKE_BUILD_TYPE=Release"
+ (string-append "-DCMAKE_INSTALL_PREFIX=" out "/bin")
+ (string-append "-DWL_INSTALL_BASEDIR=" share "/widelands")
+ (string-append "-DWL_INSTALL_DATADIR=" share "/widelands")
+ "-DOPTION_BUILD_WEBSITE_TOOLS=OFF"))))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("python" ,python)))
+ (inputs
+ `(("boost" ,boost)
+ ("glew" ,glew)
+ ("icu4c" ,icu4c)
+ ("libpng" ,libpng)
+ ("sdl" ,(sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-ttf)))
+ ("zlib" ,zlib)))
+ (home-page "https://www.widelands.org/")
+ (synopsis "Real-time strategy game with singleplayer campaigns and
+ multiplayer mode")
+ (description
+ "Widelands is a strategy game aiming for gameplay similar to Settlers II by
+ BlueByte.
+
+ In this game, you start out on a small piece of land with nothing more than
+ a few of useful resources. Using those, you can build yourself an empire
+ with many thousands of inhabitants. On your way towards this goal, you will
+ have to build up an economic infrastructure, explore the lands around you
+ and face enemies who are trying to rule the world just like you do.")
+ (license (list
+ license:gpl2+
+ license:gpl3+
+ license:expat
+ license:zlib
+ license:silofl1.1
+ license:asl2.0
+ license:cc-by-sa3.0))))