summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-04-08 12:21:42 +0200
committerGuix Patches Tester <>2020-04-08 11:24:08 +0100
commit18ef1c73c7844dbf60da1a2d76f9a37a680eea6b (patch)
treebbd19ba46419225796477f997509033402717b76
parentba6f2bda18ed19fa486a9c3e2c3baea6c66c6867 (diff)
downloadguix-patches-18ef1c73c7844dbf60da1a2d76f9a37a680eea6b.tar
guix-patches-18ef1c73c7844dbf60da1a2d76f9a37a680eea6b.tar.gz
gnu: ghc-7: Clean up package definition.
* gnu/packages/haskell.scm (ghc-7)[modules, imported-modules]: Remove the unused rpath module. [phases]: Use invoke instead of system*.
-rw-r--r--gnu/packages/haskell.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 8db650e6ae..40490cbbb6 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -183,11 +183,8 @@ top of CLISP.")
#:modules ((guix build gnu-build-system)
(guix build utils)
- (guix build rpath)
(srfi srfi-26)
(srfi srfi-1))
- #:imported-modules (,@%gnu-build-system-modules
- (guix build rpath))
#:configure-flags
(list
(string-append "--with-gmp-libraries="
@@ -214,7 +211,7 @@ top of CLISP.")
(with-directory-excursion ".."
(copy-file (assoc-ref inputs "ghc-testsuite")
"ghc-testsuite.tar.xz")
- (system* "tar" "xvf" "ghc-testsuite.tar.xz"))
+ (invoke "tar" "xvf" "ghc-testsuite.tar.xz"))
(substitute*
(list "testsuite/timeout/Makefile"
"testsuite/timeout/timeout.py"
@@ -233,7 +230,7 @@ top of CLISP.")
(with-directory-excursion ghc-bootstrap-path
(copy-file (assoc-ref inputs "ghc-binary")
"ghc-bin.tar.xz")
- (zero? (system* "tar" "xvf" "ghc-bin.tar.xz"))))
+ (invoke "tar" "xvf" "ghc-bin.tar.xz")))
(alist-cons-before
'install-bin 'configure-bin
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -265,7 +262,7 @@ top of CLISP.")
(setenv "LD_LIBRARY_PATH" gmp-lib)
;; The binaries have "/lib64/ld-linux-x86-64.so.2" hardcoded.
(for-each
- (cut system* "patchelf" "--set-interpreter" ld-so <>)
+ (cut invoke "patchelf" "--set-interpreter" ld-so <>)
binaries)
;; The binaries include a reference to libtinfo.so.5 which
;; is a subset of libncurses.so.5. We create a symlink in a
@@ -284,7 +281,7 @@ top of CLISP.")
(setenv "PATH"
(string-append (getenv "PATH") ":"
ghc-bootstrap-prefix "/bin"))
- (system*
+ (invoke
(string-append (getcwd) "/configure")
(string-append "--prefix=" ghc-bootstrap-prefix)
(string-append "--with-gmp-libraries=" gmp-lib)
@@ -294,7 +291,7 @@ top of CLISP.")
(lambda* (#:key inputs outputs #:allow-other-keys)
(with-directory-excursion
(string-append ghc-bootstrap-path "/ghc-7.8.4")
- (zero? (system* "make" "install"))))
+ (invoke "make" "install")))
%standard-phases)))))))
(native-search-paths (list (search-path-specification
(variable "GHC_PACKAGE_PATH")