summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Brown <ecbrown@ericcbrown.com>2020-04-21 11:13:11 -0500
committerGuix Patches Tester <>2020-04-21 17:31:09 +0100
commit0dd3d2c7d9795e7205d5e8e666b98c4a6685e24b (patch)
tree9c29acefa85ceda4497955c1c8c9be948ded1202
parent7681246325abcdb2f31e8db7a530920c23150bad (diff)
downloadguix-patches-0dd3d2c7d9795e7205d5e8e666b98c4a6685e24b.tar
guix-patches-0dd3d2c7d9795e7205d5e8e666b98c4a6685e24b.tar.gz
gnu: Add r-brms.
* gnu/packages/cran.scm (r-brms): New variable.
-rw-r--r--gnu/packages/cran.scm52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 70cb7cc700..13251652d4 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -21162,3 +21162,55 @@ evaluated interactively.")
Bayes factors, posterior model probabilities, and normalizing constants in
general, via different versions of bridge sampling.")
(license license:gpl2+)))
+
+(define-public r-brms
+ (package
+ (name "r-brms")
+ (version "2.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "brms" version))
+ (sha256
+ (base32
+ "1699lwkklfhjz7fddawlig552g2zvrc34mqwrzqjgl35r9fm08gs"))))
+ (properties `((upstream-name . "brms")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-abind" ,r-abind)
+ ("r-backports" ,r-backports)
+ ("r-bayesplot" ,r-bayesplot)
+ ("r-bridgesampling" ,r-bridgesampling)
+ ("r-coda" ,r-coda)
+ ("r-future" ,r-future)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-glue" ,r-glue)
+ ("r-loo" ,r-loo)
+ ("r-matrix" ,r-matrix)
+ ("r-matrixstats" ,r-matrixstats)
+ ("r-mgcv" ,r-mgcv)
+ ("r-nleqslv" ,r-nleqslv)
+ ("r-nlme" ,r-nlme)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rstan" ,r-rstan)
+ ("r-rstantools" ,r-rstantools)
+ ("r-shinystan" ,r-shinystan)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page
+ "https://github.com/paul-buerkner/brms")
+ (synopsis
+ "Bayesian Regression Models using 'Stan'")
+ (description
+ "Fit Bayesian generalized (non-)linear multivariate multilevel models
+using 'Stan' for full Bayesian inference. A wide range of distributions and
+link functions are supported, allowing users to fit -- among others -- linear,
+robust linear, count data, survival, response times, ordinal, zero-inflated,
+hurdle, and even self-defined mixture models all in a multilevel context.
+Further modeling options include non-linear and smooth terms, auto-correlation
+structures, censored data, meta-analytic standard errors, and quite a few
+more. In addition, all parameters of the response distribution can be
+predicted in order to perform distributional regression. Prior specifications
+are flexible and explicitly encourage users to apply prior distributions that
+actually reflect their beliefs. Model fit can easily be assessed and compared
+with posterior predictive checks and leave-one-out cross-validation.")
+ (license license:gpl2)))