summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2023-01-10 01:59:08 +0100
committerGuix Patches Tester <>2023-01-11 14:48:21 +0100
commit09109205c89384523764417919a36e361c61a781 (patch)
treed84b3069526439ba6f4f2c30a711a84f326516bd
parente55bc944a94134f7ff2a4ab4a0e8b9a5ac9d46d1 (diff)
downloadguix-patches-09109205c89384523764417919a36e361c61a781.tar
guix-patches-09109205c89384523764417919a36e361c61a781.tar.gz
gnu: Add gnome-shell-extension-fly-pie.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-fly-pie): New variable.
-rw-r--r--gnu/packages/gnome-xyz.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 0f3b6b6f43..c5b5d49e45 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1090,6 +1090,46 @@ animation of closing windowed applications.")
GNOME Shell, including the top panel, dash and overview.")
(license license:gpl3)))
+(define-public gnome-shell-extension-fly-pie
+ (package
+ (name "gnome-shell-extension-fly-pie")
+ (version "17")
+ (home-page "https://github.com/Schneegans/Fly-Pie")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ifkqlg2bp2vz2abakghv3zqkay0gzfljp9y252b6kpnm3fh4wvw"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan '(("."
+ "share/gnome-shell/extensions/flypie@schneegans.github.com"
+ #:include-regexp ("\\.js(on)?$" "\\.css$"
+ "\\.ui$"
+ "\\.png$"
+ "\\.xml$"
+ "\\.compiled$"
+ "\\.gresource$")))
+ #:phases (modify-phases %standard-phases
+ (add-before 'install 'compile-resources
+ (lambda _
+ (invoke "make" "resources/flypie.gresource")))
+ (add-before 'install 'compile-schemas
+ (lambda _
+ (with-directory-excursion "schemas"
+ (invoke "glib-compile-schemas" ".")))))))
+ (native-inputs (list `(,glib "bin") gettext-minimal))
+ (synopsis "Fly-Pie is an innovative marking menu written as a GNOME Shell
+extension")
+ (description
+ "Unite is a GNOME Shell extension which lets you launch applications,
+simulate hotkeys, open URLs using seamless marking menu.")
+ (license license:expat)))
+
(define-public gnome-shell-extension-radio
(package
(name "gnome-shell-extension-radio")