summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-04-25 21:43:25 -0400
committerGuix Patches Tester <>2020-04-26 03:14:16 +0100
commit07c318e22e37fe635658e114b9cb7c9c3b68f868 (patch)
treec95ec0f00fdc73a00f25793cae15e54825be1964
parent9b7e41f2d720b2a5da0d52dea6e2017d2851a640 (diff)
downloadguix-patches-07c318e22e37fe635658e114b9cb7c9c3b68f868.tar
guix-patches-07c318e22e37fe635658e114b9cb7c9c3b68f868.tar.gz
gnu: spacefm: Fix privilege management and icons.
* gnu/packages/lxde.scm (spacefm): Fix privilege management and icons. This commit contains changes that were accidentally left out in commit bf37b49cdd345bcedeb7142f61968d3a6e15e8d8.
-rw-r--r--gnu/packages/lxde.scm37
1 files changed, 30 insertions, 7 deletions
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index 9de96a21cb..3fd2eaff69 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -27,6 +27,7 @@
(define-module (gnu packages lxde)
#:use-module (gnu packages)
+ #:use-module (gnu packages admin)
#:use-module (gnu packages autotools)
#:use-module (gnu packages bash)
#:use-module (gnu packages disk)
@@ -276,7 +277,8 @@ with freedesktop.org standard.")
("intltool" ,intltool)
("pkg-config" ,pkg-config)))
(inputs
- `(("bash" ,bash)
+ `(("adwaita-icon-theme" ,adwaita-icon-theme) ; Hard-coded theme
+ ("bash" ,bash)
("cairo" ,cairo)
("curlftpfs" ,curlftpfs)
("dbus" ,dbus)
@@ -288,21 +290,42 @@ with freedesktop.org standard.")
("gtk+" ,gtk+)
("ifuse" ,ifuse)
("jmtpfs" ,jmtpfs)
+ ("ktsuss" ,ktsuss)
("libx11" ,libx11)
("lsof" ,lsof)
("pango" ,pango)
("shared-mime-info" ,shared-mime-info)
("startup-notification" ,startup-notification)
+ ("sudo" ,sudo)
("udevil" ,udevil)
("util-linux" ,util-linux)
("wget" ,wget)))
(arguments
- `(#:configure-flags (list (string-append "--with-bash-path="
- (assoc-ref %build-inputs "bash")
- "/bin/bash")
- (string-append "--sysconfdir="
- (assoc-ref %outputs "out")
- "/etc"))))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-spacefm-conf
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "etc/spacefm.conf"
+ (("#terminal_su=/bin/su")
+ (string-append "terminal_su="
+ (string-append (assoc-ref inputs "sudo")
+ "/bin/sudo"))))
+ (substitute* "etc/spacefm.conf"
+ (("#graphical_su=/usr/bin/gksu")
+ (string-append "graphical_su="
+ (string-append (assoc-ref inputs "ktsuss")
+ "/bin/ktsuss"))))
+ #t)))
+ #:configure-flags (list
+ (string-append "--with-preferable-sudo="
+ (assoc-ref %build-inputs "ktsuss")
+ "/bin/ktsuss")
+ (string-append "--with-bash-path="
+ (assoc-ref %build-inputs "bash")
+ "/bin/bash")
+ (string-append "--sysconfdir="
+ (assoc-ref %outputs "out")
+ "/etc"))))
(home-page "https://ignorantguru.github.io/spacefm/")
(synopsis "Multi-panel tabbed file manager")
(description "SpaceFM is a graphical, multi-panel, tabbed file manager