summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-11-27 14:55:50 -0600
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-11-28 06:26:06 +0100
commit0bb20a22310b36776187c8a05f11b35eb2cb41c6 (patch)
tree725b2be28df16f45f5379ed5a18b56216d74e1c8
parentefb67084b29030a8a6e5b30e456c92a72d153bf1 (diff)
downloadguix-patches-0bb20a22310b36776187c8a05f11b35eb2cb41c6.tar
guix-patches-0bb20a22310b36776187c8a05f11b35eb2cb41c6.tar.gz
gnu: Add emacs-frowny.
* gnu/packages/emacs-xyz.scm (emacs-frowny): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 35d6d87030..89956c8901 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5089,6 +5089,28 @@ at the current line number or active region. @code{git-link-commit} returns
the URL for a commit. URLs are added to the kill ring.")
(license license:gpl3+)))
+(define-public emacs-frowny
+ (package
+ (name "emacs-frowny")
+ (version "0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/duckwork/frowny.el")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "01ss3js71as1jpqcf0x9hfvapiyyhj9ni4y1n6wvqsghv5dcaiy0"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/duckwork/frowny.el")
+ (synopsis "Insert frownies in Emacs :(")
+ (description "This package ships @code{frowny-mode}, which makes it so that
+inserting a single @code{(} when after a @code{:} will not automatically close
+the parenthesis, meaning that only @code{:(} is inserted. Works with
+@code{electric-pair-mode}, @code{paredit-mode}, and others.")
+ (license license:public-domain)))
+
(define-public emacs-apache-mode
(package
(name "emacs-apache-mode")