summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-03-12 13:44:18 -0500
committerLeo Famulari <leo@famulari.name>2021-04-16 16:57:27 -0400
commitd178039a07a33751ac4f7cd582df5ae7349db4fb (patch)
tree8a68a4617a967fd34d7ee0db4bbfa4b1b58c8b61
parenta456b09c43b2505edfbd3c16c4130af4b72a30e2 (diff)
downloadguix-patches-d178039a07a33751ac4f7cd582df5ae7349db4fb.tar
guix-patches-d178039a07a33751ac4f7cd582df5ae7349db4fb.tar.gz
gnu: cairo: Absorb grafted replacement.
* gnu/packages/gtk.scm (cairo)[source]: Use cairo-CVE-2018-19876.patch and cairo-CVE-2020-35492.patch. [replacement]: Remove field. (cairo/fixed): Remove variable.
-rw-r--r--gnu/packages/gtk.scm12
1 files changed, 2 insertions, 10 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 16efb072a3..24fd48d971 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -125,11 +125,12 @@ tools have full access to view and control running applications.")
(package
(name "cairo")
(version "1.16.0")
- (replacement cairo/fixed)
(source (origin
(method url-fetch)
(uri (string-append "https://cairographics.org/releases/cairo-"
version ".tar.xz"))
+ (patches (search-patches "cairo-CVE-2018-19876.patch"
+ "cairo-CVE-2020-35492.patch"))
(sha256
(base32
"0c930mk5xr2bshbdljv005j3j8zr47gqmkry3q6qgvqky6rjjysy"))))
@@ -176,15 +177,6 @@ affine transformation (scale, rotation, shear, etc.).")
(license license:lgpl2.1) ; or Mozilla Public License 1.1
(home-page "https://cairographics.org/")))
-(define cairo/fixed
- (package
- (inherit cairo)
- (source (origin
- (inherit (package-source cairo))
- (patches (append (search-patches "cairo-CVE-2018-19876.patch"
- "cairo-CVE-2020-35492.patch")
- (origin-patches (package-source cairo))))))))
-
(define-public cairo-sans-poppler
;; Variant used to break the dependency cycle between Poppler and Cairo.
(package/inherit cairo